summaryrefslogtreecommitdiff
path: root/dev-ros/resource_retriever/resource_retriever-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/resource_retriever/resource_retriever-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/resource_retriever/resource_retriever-9999.ebuild')
-rw-r--r--dev-ros/resource_retriever/resource_retriever-9999.ebuild17
1 files changed, 13 insertions, 4 deletions
diff --git a/dev-ros/resource_retriever/resource_retriever-9999.ebuild b/dev-ros/resource_retriever/resource_retriever-9999.ebuild
index 5eb72827b5c6..4a7691efbe1e 100644
--- a/dev-ros/resource_retriever/resource_retriever-9999.ebuild
+++ b/dev-ros/resource_retriever/resource_retriever-9999.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/resource_retriever"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
inherit ros-catkin
@@ -15,9 +14,19 @@ IUSE=""
RDEPEND="
dev-ros/rosconsole
- dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
net-misc/curl
- dev-python/rospkg[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ if has network-sandbox ${FEATURES}; then
+ einfo "Skipping network tests due to network sandbox"
+ export GTEST_FILTER='-Retriever.http'
+ export NOSE_TESTMATCH='^(?!test_http).*'
+ fi
+ ros-catkin_src_test
+}