summaryrefslogtreecommitdiff
path: root/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild')
-rw-r--r--dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
new file mode 100644
index 000000000000..87a1c621b8d2
--- /dev/null
+++ b/dev-ros/qt_gui_py_common/qt_gui_py_common-0.3.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common functionality for ROS RQT GUI plugins written in Python"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"