summaryrefslogtreecommitdiff
path: root/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild')
-rw-r--r--dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild b/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
new file mode 100644
index 000000000000..bca6c4fa19d8
--- /dev/null
+++ b/dev-ros/qt_gui_app/qt_gui_app-0.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"