summaryrefslogtreecommitdiff
path: root/dev-ros/qt_gui/qt_gui-0.3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-ros/qt_gui/qt_gui-0.3.11.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-ros/qt_gui/qt_gui-0.3.11.ebuild')
-rw-r--r--dev-ros/qt_gui/qt_gui-0.3.11.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/qt_gui/qt_gui-0.3.11.ebuild b/dev-ros/qt_gui/qt_gui-0.3.11.ebuild
new file mode 100644
index 000000000000..ef3a31a6467e
--- /dev/null
+++ b/dev-ros/qt_gui/qt_gui-0.3.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"