summaryrefslogtreecommitdiff
path: root/dev-ros/pr2_description
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/pr2_description
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/pr2_description')
-rw-r--r--dev-ros/pr2_description/Manifest6
-rw-r--r--dev-ros/pr2_description/files/tests.patch13
-rw-r--r--dev-ros/pr2_description/metadata.xml11
-rw-r--r--dev-ros/pr2_description/pr2_description-1.12.0.ebuild22
-rw-r--r--dev-ros/pr2_description/pr2_description-9999.ebuild22
5 files changed, 74 insertions, 0 deletions
diff --git a/dev-ros/pr2_description/Manifest b/dev-ros/pr2_description/Manifest
new file mode 100644
index 000000000000..a038a85b0c01
--- /dev/null
+++ b/dev-ros/pr2_description/Manifest
@@ -0,0 +1,6 @@
+AUX tests.patch 582 SHA256 c1cb97df75d7ce78906d0837433753eb2d603bb65ff4627622f287ee29e87564 SHA512 435c0f6b38ffd49282971d563f4e68daa482b63da3b44ff2599ff68f08be404b7921e125463494970a2c70ce938871c7d7bbea00d06c0ce61a76ff8117dcea8b WHIRLPOOL 99c3eb993d151fe84a22ce10be795e6a7faaf4ccd27adf3fc73fc0623bf70d22b82a8febc28cc6dd14babfa4439a65423111dd358754018dbfd2810d58724f6c
+DIST pr2_common-1.12.0.tar.gz 33598910 SHA256 edb51715498d51c6217e1eda05a9aae575fdf1f86fcb5ea07af913ec976ef3ff SHA512 da933ff9521a9337198a890e0ba10281510b861b4bff3023e7d251251f7ef7f8579f86b2992238975329c5c63ecdf00b17e895f1e0dec4e180336860fdd0c921 WHIRLPOOL e5f8184d126a10c8c68349604346f25b5a4a4a622e27204fe135ec6aaf751ff4bc15d5865a34e74857b25cddae25ae91d4882e1dba2d9c72078a4950a0a036db
+EBUILD pr2_description-1.12.0.ebuild 549 SHA256 e64d485cda1557e426b6ba360ccaf0d57d4e6c002549f345b31c5d8bad5830e9 SHA512 7fbcc6f38b7363adcdb226d8b8a30c404f62477f5fbdfd17d89b263ffd2f29fff3d24d6af51145484857a9485d922d3079db06e470b42ef7f05093e7717a1ccf WHIRLPOOL fe6785171d11dccffb6da10bae2258118000c0cf026640e459c8b47c46321ed5137d121904ad2bf5022a0ee0d6171356f9ff9b3a825f44c8a21e9b62fb6fe9ba
+EBUILD pr2_description-9999.ebuild 549 SHA256 e64d485cda1557e426b6ba360ccaf0d57d4e6c002549f345b31c5d8bad5830e9 SHA512 7fbcc6f38b7363adcdb226d8b8a30c404f62477f5fbdfd17d89b263ffd2f29fff3d24d6af51145484857a9485d922d3079db06e470b42ef7f05093e7717a1ccf WHIRLPOOL fe6785171d11dccffb6da10bae2258118000c0cf026640e459c8b47c46321ed5137d121904ad2bf5022a0ee0d6171356f9ff9b3a825f44c8a21e9b62fb6fe9ba
+MISC ChangeLog 3233 SHA256 d67392c7b3a06e38657c7e722fe14237b0151e10d678f1fd877517e14e9b17a2 SHA512 126111c83d88b0155ea28fd0d3f3388e1af02932bb5c176532610d9bd22b77e17dc9380a6d6f81c341505cea89fa4dff60519884d3b69caa8c799828a456153c WHIRLPOOL 5c04f26e7e19ac3319ba59e757ffc4b902ac392a69d15cd285ba3caf6327f2a66254ce38c1ddacab2d26077f0a54e91285c604c9903503f7fe8f00edade7aaf1
+MISC metadata.xml 328 SHA256 2b53b86d1a28796cd065b747190cbbbfcd64e08513a4472d1d93f399e28ffc49 SHA512 2f52806adfce77e7d54809d57a0b8b59b26f25da96f50f10672ed76ce8bda8e4555f1531af953e61cd1cfa82d46d46a3760b12b537ffcc191407125604abcbbc WHIRLPOOL feba9590a62af07e9c19480482dc25c96015e188bc16c6311d6fe3ea4bc2c1847247168af66b627295852a93bc1aa299ff972b14606867b1ebfbe125c80bed8b
diff --git a/dev-ros/pr2_description/files/tests.patch b/dev-ros/pr2_description/files/tests.patch
new file mode 100644
index 000000000000..40c3a378d45d
--- /dev/null
+++ b/dev-ros/pr2_description/files/tests.patch
@@ -0,0 +1,13 @@
+Index: pr2_common-1.12.0/pr2_description/test/test_urdf.cpp
+===================================================================
+--- pr2_common-1.12.0.orig/pr2_description/test/test_urdf.cpp
++++ pr2_common-1.12.0/pr2_description/test/test_urdf.cpp
+@@ -100,7 +100,7 @@ int walker( std::string & result, int& t
+ }
+ xml_file.close();
+
+- boost::shared_ptr<urdf::ModelInterface> robot = urdf::parseURDF(xml_string);
++ std::shared_ptr<urdf::ModelInterface> robot = urdf::parseURDF(xml_string);
+ if (!robot) test_result = test_result || 1;
+
+ }
diff --git a/dev-ros/pr2_description/metadata.xml b/dev-ros/pr2_description/metadata.xml
new file mode 100644
index 000000000000..f90f426b538b
--- /dev/null
+++ b/dev-ros/pr2_description/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pr2/pr2_common</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/pr2_description/pr2_description-1.12.0.ebuild b/dev-ros/pr2_description/pr2_description-1.12.0.ebuild
new file mode 100644
index 000000000000..1a73af70cf05
--- /dev/null
+++ b/dev-ros/pr2_description/pr2_description-1.12.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Description (mechanical, kinematic, visual, etc.) of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/xacro[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-ros/convex_decomposition
+ dev-ros/ivcon
+ test? ( dev-libs/urdfdom dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
diff --git a/dev-ros/pr2_description/pr2_description-9999.ebuild b/dev-ros/pr2_description/pr2_description-9999.ebuild
new file mode 100644
index 000000000000..1a73af70cf05
--- /dev/null
+++ b/dev-ros/pr2_description/pr2_description-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/pr2/pr2_common"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Description (mechanical, kinematic, visual, etc.) of the PR2 robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/xacro[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-ros/convex_decomposition
+ dev-ros/ivcon
+ test? ( dev-libs/urdfdom dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )