summaryrefslogtreecommitdiff
path: root/dev-ros/pointcloud_to_laserscan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/pointcloud_to_laserscan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/pointcloud_to_laserscan')
-rw-r--r--dev-ros/pointcloud_to_laserscan/Manifest4
-rw-r--r--dev-ros/pointcloud_to_laserscan/metadata.xml11
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0-r1.ebuild26
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild26
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-ros/pointcloud_to_laserscan/Manifest b/dev-ros/pointcloud_to_laserscan/Manifest
new file mode 100644
index 000000000000..d15b16ee2218
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/Manifest
@@ -0,0 +1,4 @@
+DIST pointcloud_to_laserscan-1.4.0.tar.gz 6502 BLAKE2B 02614ce3e046f4b6c828df7121dcd5a2d033e8fefa979a8541127684d5ea6bb40d74412ea9c1ccffc934aa7172343968f75198f444b2ca38391318f584e40901 SHA512 f54d65edc4eda2e97d75ed26b1d374a669f188c4ef2426730312ae479e051a0834abb782cdd00febbd8dc97cb6a0723b6a735d2cbf07e2f8260ad0e54e79376f
+EBUILD pointcloud_to_laserscan-1.4.0-r1.ebuild 567 BLAKE2B 3943a2ee24ad44c920abbd54409a7250c1b76893009efdba5da8e3ff31d97efe6d684aea131ae6c1ac1a4dd817d767398b72d4e977afda785c970f967307f008 SHA512 17be604706279edb4a20b0c1b7024be4123038e415c4d52c41c328ac4c427a3ba72367267c20d99f10872850264ea3eda12f38eaeacd071c399c5eefd2c6256b
+EBUILD pointcloud_to_laserscan-9999.ebuild 567 BLAKE2B 3943a2ee24ad44c920abbd54409a7250c1b76893009efdba5da8e3ff31d97efe6d684aea131ae6c1ac1a4dd817d767398b72d4e977afda785c970f967307f008 SHA512 17be604706279edb4a20b0c1b7024be4123038e415c4d52c41c328ac4c427a3ba72367267c20d99f10872850264ea3eda12f38eaeacd071c399c5eefd2c6256b
+MISC metadata.xml 352 BLAKE2B e6e84324ce9e250cbcbbc842560bd902aec079b7be5cfa60ba2a3b1e19d7e998f21fdc1bacff7addb2325f99d0b9f6fb0d6b928f7111a99c591174da8db34eab SHA512 d25a2c3b70b16e29ba73ea87630bfc1b82ecbde5235a02b02d6ee98b8bbc50fd5899f8ff99c46fb392f4c84841a5ae2781bec9afd89cf53bdd8631eea02ee0e9
diff --git a/dev-ros/pointcloud_to_laserscan/metadata.xml b/dev-ros/pointcloud_to_laserscan/metadata.xml
new file mode 100644
index 000000000000..d1ed1f0a952a
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/pointcloud_to_laserscan</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0-r1.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..36c5cfc0838d
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.4.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
new file mode 100644
index 000000000000..36c5cfc0838d
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"