summaryrefslogtreecommitdiff
path: root/dev-ros/octomap_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/octomap_msgs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/octomap_msgs')
-rw-r--r--dev-ros/octomap_msgs/Manifest4
-rw-r--r--dev-ros/octomap_msgs/metadata.xml11
-rw-r--r--dev-ros/octomap_msgs/octomap_msgs-0.3.3.ebuild19
-rw-r--r--dev-ros/octomap_msgs/octomap_msgs-9999.ebuild19
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/octomap_msgs/Manifest b/dev-ros/octomap_msgs/Manifest
new file mode 100644
index 000000000000..78a3c5d2fbb9
--- /dev/null
+++ b/dev-ros/octomap_msgs/Manifest
@@ -0,0 +1,4 @@
+DIST octomap_msgs-0.3.3.tar.gz 4566 BLAKE2B f0f2d7591b203b05d40722e7a9b52ca831af63e36c5026004e5c727baea0ffe4d5b6206ded90aaa6893b48fa2a493b880b00c28afdf449f906e8ca1e2c786660 SHA512 b88d708e981cdac0c1180013305cee8a107e7019aacb74152c70be828cb0d581fac0e6525c0599328dd8dd5b0e3df9880773752f36d94d35b3435c38584ddbe1
+EBUILD octomap_msgs-0.3.3.ebuild 504 BLAKE2B df0802a9e2e45d83a1d8b6f15607b55c228d54b74d7127eb609ecc8bfc7722db9f935582aa0d77faa81b6363f0a302048e1fd33e9341b518c2ba62a3b46d9940 SHA512 ec33403c53a5cb69798fdd55732020611d75ce7ae2ed3165034bdf0b4f9548fc1ae51c57e559d5041ce2925e1339831c1b261055310e7ca46e4d4f55f68cb813
+EBUILD octomap_msgs-9999.ebuild 504 BLAKE2B df0802a9e2e45d83a1d8b6f15607b55c228d54b74d7127eb609ecc8bfc7722db9f935582aa0d77faa81b6363f0a302048e1fd33e9341b518c2ba62a3b46d9940 SHA512 ec33403c53a5cb69798fdd55732020611d75ce7ae2ed3165034bdf0b4f9548fc1ae51c57e559d5041ce2925e1339831c1b261055310e7ca46e4d4f55f68cb813
+MISC metadata.xml 334 BLAKE2B d259b147c66e00b0efa297c0491593ffd4873606e0adad96742c146d46c785a3a4757d3b369dd98582a7c9ed00909a9bfec6ef360afef9cd5f4f628a4071e9fc SHA512 0c7997d8652614b7b37d6bb9126d1cf89b0b9aebb72cee36ab8229894725e6d0d10002340e664b5a3d05e4b9536f7d5984fdabfd0df1a53f6026d97508231205
diff --git a/dev-ros/octomap_msgs/metadata.xml b/dev-ros/octomap_msgs/metadata.xml
new file mode 100644
index 000000000000..4925677e2a30
--- /dev/null
+++ b/dev-ros/octomap_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OctoMap/octomap_msgs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/octomap_msgs/octomap_msgs-0.3.3.ebuild b/dev-ros/octomap_msgs/octomap_msgs-0.3.3.ebuild
new file mode 100644
index 000000000000..195ada7c120d
--- /dev/null
+++ b/dev-ros/octomap_msgs/octomap_msgs-0.3.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages and serializations / conversion for the OctoMap library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/octomap_msgs/octomap_msgs-9999.ebuild b/dev-ros/octomap_msgs/octomap_msgs-9999.ebuild
new file mode 100644
index 000000000000..195ada7c120d
--- /dev/null
+++ b/dev-ros/octomap_msgs/octomap_msgs-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages and serializations / conversion for the OctoMap library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"