summaryrefslogtreecommitdiff
path: root/dev-ros/navfn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/navfn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/navfn')
-rw-r--r--dev-ros/navfn/Manifest7
-rw-r--r--dev-ros/navfn/files/pgm_h_location.patch26
-rw-r--r--dev-ros/navfn/metadata.xml11
-rw-r--r--dev-ros/navfn/navfn-1.15.1-r1.ebuild39
-rw-r--r--dev-ros/navfn/navfn-1.15.2.ebuild39
-rw-r--r--dev-ros/navfn/navfn-9999.ebuild39
6 files changed, 161 insertions, 0 deletions
diff --git a/dev-ros/navfn/Manifest b/dev-ros/navfn/Manifest
new file mode 100644
index 000000000000..37f04f6d11b1
--- /dev/null
+++ b/dev-ros/navfn/Manifest
@@ -0,0 +1,7 @@
+AUX pgm_h_location.patch 900 BLAKE2B 2816bc6803bce70d14f5fcf10161316961ffd265d94a36e90f7d98bd381a4966bd924e352cda2f859e07ea25547e62e0d6381afa1fa3b488364634b20730830c SHA512 4c3286e18d922d292858e8fc574cc440c344ae182133539efca93cb25e16dc78149efe521499024751a46f2b4d1b63516276f1e0510028114357520d4a560d81
+DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+EBUILD navfn-1.15.1-r1.ebuild 913 BLAKE2B 9d84a8b7bc87825f8593a325f2d39ae0146edd6d299d0b4f5151e3f7f4486d837fb4c577162efa08a92e43fd6d0041b87ec403fe00b309554d97d74eee7a72c4 SHA512 f6cfd0c8a4abf07ee4440fa5bb399d6ac6295427356f2dace3728b87c01e0e359917900218b3723ee60fad37672e41b328a9c5109cff4b640a58b16b27108f54
+EBUILD navfn-1.15.2.ebuild 913 BLAKE2B 9d405dcad1e3e9e79d050bc26ece8b81e8a8d67baa7c218abbde2317ba59d87ece1f318b327014caca5e437e0a93ebd66b9c970e154da4f3e34c04faafd5b42b SHA512 b0a6c3bc2afebd03b7ecf7618396dbc29c968b91ab1b1c2c6fb937c7607e05269ed72221655a64c71c717560f68219b180139072ac3a67f49a7abc4314af8e83
+EBUILD navfn-9999.ebuild 913 BLAKE2B 9d84a8b7bc87825f8593a325f2d39ae0146edd6d299d0b4f5151e3f7f4486d837fb4c577162efa08a92e43fd6d0041b87ec403fe00b309554d97d74eee7a72c4 SHA512 f6cfd0c8a4abf07ee4440fa5bb399d6ac6295427356f2dace3728b87c01e0e359917900218b3723ee60fad37672e41b328a9c5109cff4b640a58b16b27108f54
+MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/navfn/files/pgm_h_location.patch b/dev-ros/navfn/files/pgm_h_location.patch
new file mode 100644
index 000000000000..683a9556ddc0
--- /dev/null
+++ b/dev-ros/navfn/files/pgm_h_location.patch
@@ -0,0 +1,26 @@
+Index: navigation-1.13.0/navfn/src/navtest.cpp
+===================================================================
+--- navigation-1.13.0.orig/navfn/src/navtest.cpp
++++ navigation-1.13.0/navfn/src/navtest.cpp
+@@ -21,7 +21,7 @@ using namespace navfn;
+ extern "C" {
+ #include <stdio.h>
+ // pgm.h is not very friendly with system headers... need to undef max() and min() afterwards
+-#include <pgm.h>
++#include <netpbm/pgm.h>
+ #undef max
+ #undef min
+ }
+Index: navigation-1.13.0/navfn/src/read_pgm_costmap.cpp
+===================================================================
+--- navigation-1.13.0.orig/navfn/src/read_pgm_costmap.cpp
++++ navigation-1.13.0/navfn/src/read_pgm_costmap.cpp
+@@ -37,7 +37,7 @@
+ extern "C" {
+ #include <stdio.h>
+ // pgm.h is not very friendly with system headers... need to undef max() and min() afterwards
+-#include <pgm.h>
++#include <netpbm/pgm.h>
+ #undef max
+ #undef min
+ }
diff --git a/dev-ros/navfn/metadata.xml b/dev-ros/navfn/metadata.xml
new file mode 100644
index 000000000000..7408fdf7047f
--- /dev/null
+++ b/dev-ros/navfn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/navfn/navfn-1.15.1-r1.ebuild b/dev-ros/navfn/navfn-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..66cdbd1cb7d1
--- /dev/null
+++ b/dev-ros/navfn/navfn-1.15.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )
diff --git a/dev-ros/navfn/navfn-1.15.2.ebuild b/dev-ros/navfn/navfn-1.15.2.ebuild
new file mode 100644
index 000000000000..51db8c953072
--- /dev/null
+++ b/dev-ros/navfn/navfn-1.15.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )
diff --git a/dev-ros/navfn/navfn-9999.ebuild b/dev-ros/navfn/navfn-9999.ebuild
new file mode 100644
index 000000000000..66cdbd1cb7d1
--- /dev/null
+++ b/dev-ros/navfn/navfn-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+ dev-libs/boost:=[threads]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )