summaryrefslogtreecommitdiff
path: root/dev-ros/move_base_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/move_base_msgs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/move_base_msgs')
-rw-r--r--dev-ros/move_base_msgs/Manifest4
-rw-r--r--dev-ros/move_base_msgs/metadata.xml11
-rw-r--r--dev-ros/move_base_msgs/move_base_msgs-1.13.0.ebuild20
-rw-r--r--dev-ros/move_base_msgs/move_base_msgs-9999.ebuild20
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-ros/move_base_msgs/Manifest b/dev-ros/move_base_msgs/Manifest
new file mode 100644
index 000000000000..efbbe4053d59
--- /dev/null
+++ b/dev-ros/move_base_msgs/Manifest
@@ -0,0 +1,4 @@
+DIST navigation_msgs-1.13.0.tar.gz 2251 BLAKE2B b70ade2d296f8a94ae89286caa4f23adba5ac5c058ccfcdf6a35a9bac03e5238a37bcd91bbf99f62d3fe806639e8a655c5fcc9391e637e37238f0421805903dd SHA512 e7b4a83bbbd5384f72d1a9d7e3544cde718728ba2a2562b3c0da5b5fd7db146faf8c717d4af2509eaf1ff545ac85da121f7e37cb7b6b53c8a5b8d683c6b4e66c
+EBUILD move_base_msgs-1.13.0.ebuild 547 BLAKE2B f3974a7b05271aeee843895e5ba3b28766ba22dd5c0e5efb4bec9667a64b044c545948d737724cfab1a899cc8cec485a969663423476f98fdc8e272cba38654d SHA512 53060b7314eecd093a742ddc17868ce38a606396f3c0f9b43cd7c06d69ab77ad8a3c0583872533ec6558adc5f9e89f6aac55c7d5c8f6e1c05442a6e4e0d15b81
+EBUILD move_base_msgs-9999.ebuild 547 BLAKE2B f3974a7b05271aeee843895e5ba3b28766ba22dd5c0e5efb4bec9667a64b044c545948d737724cfab1a899cc8cec485a969663423476f98fdc8e272cba38654d SHA512 53060b7314eecd093a742ddc17868ce38a606396f3c0f9b43cd7c06d69ab77ad8a3c0583872533ec6558adc5f9e89f6aac55c7d5c8f6e1c05442a6e4e0d15b81
+MISC metadata.xml 342 BLAKE2B c278231941f53347e7457813d64fc0bf8b32bcacbfddc955c8d90538c9ae9c23504c51747c32ef7f8c5555c22d25bd34c1a5185df6d864b6f0509fdccedbcdd0 SHA512 6b28c6c3ff5f68ebfe8ba768c80ebc61c054453fde126fc64aa406e69fdf2f3174031930b8830144ba25401354df016f8179ab3d16c50d339b486a13421dd684
diff --git a/dev-ros/move_base_msgs/metadata.xml b/dev-ros/move_base_msgs/metadata.xml
new file mode 100644
index 000000000000..8279667632da
--- /dev/null
+++ b/dev-ros/move_base_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation_msgs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/move_base_msgs/move_base_msgs-1.13.0.ebuild b/dev-ros/move_base_msgs/move_base_msgs-1.13.0.ebuild
new file mode 100644
index 000000000000..07bf1992528e
--- /dev/null
+++ b/dev-ros/move_base_msgs/move_base_msgs-1.13.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Holds the action description and relevant messages for the move_base package"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/move_base_msgs/move_base_msgs-9999.ebuild b/dev-ros/move_base_msgs/move_base_msgs-9999.ebuild
new file mode 100644
index 000000000000..07bf1992528e
--- /dev/null
+++ b/dev-ros/move_base_msgs/move_base_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation_msgs"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Holds the action description and relevant messages for the move_base package"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"