summaryrefslogtreecommitdiff
path: root/dev-ros/message_to_tf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/message_to_tf
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/message_to_tf')
-rw-r--r--dev-ros/message_to_tf/Manifest5
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild24
-rw-r--r--dev-ros/message_to_tf/message_to_tf-9999.ebuild24
-rw-r--r--dev-ros/message_to_tf/metadata.xml11
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/message_to_tf/Manifest b/dev-ros/message_to_tf/Manifest
new file mode 100644
index 000000000000..19770f31dade
--- /dev/null
+++ b/dev-ros/message_to_tf/Manifest
@@ -0,0 +1,5 @@
+DIST hector_localization-0.3.0.tar.gz 73656 SHA256 36dd8dba4496e50df65505707ade089c1e2dfe1855b78081f68706a104c38326 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df WHIRLPOOL 26ef7ff7b5011b81349448954bec84f70841d543668d43e4b50783e48580eb2632ba8713d3df1a75d5e1f2ada7fd60d8dab551cf4392ea4effc49a4272c4855e
+EBUILD message_to_tf-0.3.0.ebuild 618 SHA256 3547547869ef1770ddfdd3d1c7349b330ee2966322e1e8dfcf672d9b800d4c1b SHA512 f5a23da8ea1d7c371554b7b459497098ba42be625291773824729a046c4903c4d2bb97f8417d9d3267effa6774dfa4ab60c148d440e0b7b0ba16d9ca97823e25 WHIRLPOOL eca89768d29c7c5dc84d893ebc0bdb697dcda0fdfa85756cf4cfdd590ccd4e7f8a1fe7af628b53bef91db0c4081dabdf8c8e7b3904f19c5f0d5b20854380c1ec
+EBUILD message_to_tf-9999.ebuild 618 SHA256 3547547869ef1770ddfdd3d1c7349b330ee2966322e1e8dfcf672d9b800d4c1b SHA512 f5a23da8ea1d7c371554b7b459497098ba42be625291773824729a046c4903c4d2bb97f8417d9d3267effa6774dfa4ab60c148d440e0b7b0ba16d9ca97823e25 WHIRLPOOL eca89768d29c7c5dc84d893ebc0bdb697dcda0fdfa85756cf4cfdd590ccd4e7f8a1fe7af628b53bef91db0c4081dabdf8c8e7b3904f19c5f0d5b20854380c1ec
+MISC ChangeLog 1704 SHA256 61a287fe841af7b1caabe0fe17dc957ed5feaf7f52795800e7693857b9976c08 SHA512 4a10405d93898eb920ff00e5862d5c1e3d406afd34d5049e44a3a91492ec5d368f1b48da1041f45c865606f3b5976b2f5a9c9263f06a3c0cbe2f48b89c2a3aa6 WHIRLPOOL 88788f883e6a5671d37f751ef936c4375997d43d3899d2d8b312b121b41a3ce8342752f03422c82af88aaf2734b2fb663e6ae5344dea4a8acb7ec7e000c41cd6
+MISC metadata.xml 354 SHA256 7fbc9041a508b4280e3ff8c43938f8d673a12df4669e2d771792ae2380515cd5 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420 WHIRLPOOL 06c01e937faa41d66f13b986cdcb1f0b4d92659c869909d3c8d6864cc2f7b6e25d03240302df7fe5270e2e50cf6a0ce901db8f4d79e032548bf20897db83b824
diff --git a/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
new file mode 100644
index 000000000000..5b2da944b6a4
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/message_to_tf-9999.ebuild b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
new file mode 100644
index 000000000000..5b2da944b6a4
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/message_to_tf/metadata.xml b/dev-ros/message_to_tf/metadata.xml
new file mode 100644
index 000000000000..ee6ea29b2d58
--- /dev/null
+++ b/dev-ros/message_to_tf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
+ </upstream>
+</pkgmetadata>