summaryrefslogtreecommitdiff
path: root/dev-ros/message_to_tf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ros/message_to_tf
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ros/message_to_tf')
-rw-r--r--dev-ros/message_to_tf/Manifest2
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.4.0.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/message_to_tf/Manifest b/dev-ros/message_to_tf/Manifest
index eba36875515c..7b5af6b6639c 100644
--- a/dev-ros/message_to_tf/Manifest
+++ b/dev-ros/message_to_tf/Manifest
@@ -1,4 +1,6 @@
DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
+DIST hector_localization-0.4.0.tar.gz 75100 BLAKE2B afb6acb1444299c7ca47f25da7d7ad83a2363c98a6b1ed21756cdd5cf63e758b7e4e9d7ea806c7c748dc5e3606bafbe62df612a42597e86ec556696211dc8af9 SHA512 18fc8cb2f51ec978e309a627f12b896aff984fdbe2f2038c47369bd44479b3c739fad586b325c6962bb17c49e46eb7568f8af5af085fbc87749ddb2616ad34c3
EBUILD message_to_tf-0.3.0.ebuild 611 BLAKE2B 5c7534594ca539dfc4722359537a546859e0815e4b460eadcead11cd1074654c7a4be9480074b70528a3f4cf429dda0d6c80bb34143ef17943ed18bbdb252060 SHA512 b20087191da892d03baad6aef63f653599c2c26e3475507888a1b2f44eeb36e76c920a77dd79b4a3060da6713aba157ff124510c1332b2645f84f7c1e5c9cdc6
+EBUILD message_to_tf-0.4.0.ebuild 611 BLAKE2B fbc2ee2e48999471f3206d891ae9130f9f0facb4cc84b76161303f087e69b2a41b64c02bfe8d230972a8326b255c58f72f793ecf7c307b05d86bdd36bbbe4a5e SHA512 5c3b8bc11eba91b432169615a6b7f8a8c39b81e618211aae20f0e2453a083a02e7f8fc259a13f096af237a86a69b6246630ef8253c82de51c9ba55ca8e9567fb
EBUILD message_to_tf-9999.ebuild 611 BLAKE2B 5c7534594ca539dfc4722359537a546859e0815e4b460eadcead11cd1074654c7a4be9480074b70528a3f4cf429dda0d6c80bb34143ef17943ed18bbdb252060 SHA512 b20087191da892d03baad6aef63f653599c2c26e3475507888a1b2f44eeb36e76c920a77dd79b4a3060da6713aba157ff124510c1332b2645f84f7c1e5c9cdc6
MISC metadata.xml 354 BLAKE2B 8fa87680be83a7fc421afc00fa7e203bd512c42324cee5ce59f08a6acdfacdd09a8427e547982ccff17253589708a0556e51420188c3639ab638df4994e4edb7 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420
diff --git a/dev-ros/message_to_tf/message_to_tf-0.4.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.4.0.ebuild
new file mode 100644
index 000000000000..29d05af7cf53
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-0.4.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"