summaryrefslogtreecommitdiff
path: root/dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild')
-rw-r--r--dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild b/dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild
new file mode 100644
index 000000000000..80513fb6f3af
--- /dev/null
+++ b/dev-ros/mavros_msgs/mavros_msgs-0.19.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Messages for MAVROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"