summaryrefslogtreecommitdiff
path: root/dev-ros/joint_state_publisher_gui
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/joint_state_publisher_gui
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/joint_state_publisher_gui')
-rw-r--r--dev-ros/joint_state_publisher_gui/Manifest4
-rw-r--r--dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-1.15.0.ebuild23
-rw-r--r--dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-9999.ebuild23
-rw-r--r--dev-ros/joint_state_publisher_gui/metadata.xml11
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher_gui/Manifest b/dev-ros/joint_state_publisher_gui/Manifest
new file mode 100644
index 000000000000..df08f64fc57a
--- /dev/null
+++ b/dev-ros/joint_state_publisher_gui/Manifest
@@ -0,0 +1,4 @@
+DIST joint_state_publisher-1.15.0.tar.gz 27974 BLAKE2B e0293f3c9496dfa47bd07e9825ed399e05b53f80947aecba228c3b153384fe5ceef808fa7a1ff5678448ef263c439bbcdae4e475bee206554f2cdff785175b1a SHA512 58387785f93195ab4b1f6a2d54f8d7765c5cd34df6a2bf5ab00caf032b5b1093fc9ec02e7217cd554cdcc37545295dff5652c295fb3ea91a549d23b83db02dbc
+EBUILD joint_state_publisher_gui-1.15.0.ebuild 597 BLAKE2B f70d3a73e74ce21a96fc8919d0e87054be04f6d540cf11b43f096619fa833377679780f5af916279a35c37fd80494d9061a30d884470a7db01cc5bbcd922a181 SHA512 77fb12dc9f70ecd8a1dfdff9caf75e762e2ec80e1732784315d0bf83f01083ea2a8be82ee167d6b6a25e0b7a023f4767fb2f76fccb05e48d9c246ed2755d621d
+EBUILD joint_state_publisher_gui-9999.ebuild 597 BLAKE2B f70d3a73e74ce21a96fc8919d0e87054be04f6d540cf11b43f096619fa833377679780f5af916279a35c37fd80494d9061a30d884470a7db01cc5bbcd922a181 SHA512 77fb12dc9f70ecd8a1dfdff9caf75e762e2ec80e1732784315d0bf83f01083ea2a8be82ee167d6b6a25e0b7a023f4767fb2f76fccb05e48d9c246ed2755d621d
+MISC metadata.xml 339 BLAKE2B b435f6689ab4c75a5dc4850793e70300e465c96c90b6162eaf488a069eb259e282f2534300ae1388036ba77058df57d8d43a4c60bdc1c336e1f3901a4d8bbb4e SHA512 44432f918f72fd087c1747bf5b42743651c6cf5a457c3d9cfc25206dbf24396b09b3565118895c6e1794befd027db1842dc7fd33f3e74031e0ba74be72475df1
diff --git a/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-1.15.0.ebuild b/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-1.15.0.ebuild
new file mode 100644
index 000000000000..4a20aa38a90b
--- /dev/null
+++ b/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-1.15.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/joint_state_publisher[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
diff --git a/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-9999.ebuild b/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-9999.ebuild
new file mode 100644
index 000000000000..4a20aa38a90b
--- /dev/null
+++ b/dev-ros/joint_state_publisher_gui/joint_state_publisher_gui-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/joint_state_publisher[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
diff --git a/dev-ros/joint_state_publisher_gui/metadata.xml b/dev-ros/joint_state_publisher_gui/metadata.xml
new file mode 100644
index 000000000000..b74086ddd5fa
--- /dev/null
+++ b/dev-ros/joint_state_publisher_gui/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/joint_state_publisher</remote-id>
+ </upstream>
+</pkgmetadata>