summaryrefslogtreecommitdiff
path: root/dev-ros/joint_state_publisher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/joint_state_publisher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/joint_state_publisher')
-rw-r--r--dev-ros/joint_state_publisher/Manifest6
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild22
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild24
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild24
-rw-r--r--dev-ros/joint_state_publisher/metadata.xml11
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/Manifest b/dev-ros/joint_state_publisher/Manifest
new file mode 100644
index 000000000000..1a3e27cb6568
--- /dev/null
+++ b/dev-ros/joint_state_publisher/Manifest
@@ -0,0 +1,6 @@
+DIST joint_state_publisher-1.12.13.tar.gz 20658 BLAKE2B 8f0d4b1bbe5e381cb20476461a132510e0eed0cde6564557bbcf4d3c07f9036b55fb1b8ea26ef55e0085dfd2f32705d6d4d25b35c915e349c62da17e755b65c1 SHA512 012e2c4b522c9314169323066e3975d72597783a587192a176cc7f7c4b0d59a1dfd3724a57c80d6d6a628640130d235fb9fc8620f0abcd8ef81776689d05e8f1
+DIST robot_model-1.12.11.tar.gz 277822 BLAKE2B 3bdd2b931ddfd062594ccb2be4ce6d4863a5fa66f538c3ee48c3600b3be249d267f9d03aa9a701bc6ab22c4297d659a24da668fedcd25c75fe128c43cc781be0 SHA512 8dea6fc72e9beaddbf9a82cb177561cb89c69ef8f58f0c4882598f6cc33a0e10564d9696f07b6f4e3e3404d3f1f5236e54eea4b8d249be0a216cd3ce12a03cde
+EBUILD joint_state_publisher-1.12.11.ebuild 532 BLAKE2B a37038eb7f2a6d9a3ac4ea08518b6290d08c0248f470c6884dcf87e4fa3b0c5d1f15d0ca614a3b9436dd15bc397a3f56f7eb3c9ecd5f99e2d8ab0abca9ae64ad SHA512 b0126544edc2e736160a1e1967fb587c48aab8341fbb0fde41aa2adccafb123b19816b6d7d42bc60058835326f6a77677df481daf5328f655516971549357df1
+EBUILD joint_state_publisher-1.12.13.ebuild 606 BLAKE2B c1cf841a267a048cf82380760372b47e8644bc3465df1fe41f1ab501da55de5ce333a1c50a18cd0690aae5e7555df2601ed79ab7e0ed033171e04a40c778bf97 SHA512 842ae750a98a69b4c4bea0912ea37c182f20226cf6d681b32f6cd784440d85d61f4800a97867fbd6b85f4a6cf76605acb74c604d9cf4d07e690308f82c982f1e
+EBUILD joint_state_publisher-9999.ebuild 606 BLAKE2B c1cf841a267a048cf82380760372b47e8644bc3465df1fe41f1ab501da55de5ce333a1c50a18cd0690aae5e7555df2601ed79ab7e0ed033171e04a40c778bf97 SHA512 842ae750a98a69b4c4bea0912ea37c182f20226cf6d681b32f6cd784440d85d61f4800a97867fbd6b85f4a6cf76605acb74c604d9cf4d07e690308f82c982f1e
+MISC metadata.xml 339 BLAKE2B b435f6689ab4c75a5dc4850793e70300e465c96c90b6162eaf488a069eb259e282f2534300ae1388036ba77058df57d8d43a4c60bdc1c336e1f3901a4d8bbb4e SHA512 44432f918f72fd087c1747bf5b42743651c6cf5a457c3d9cfc25206dbf24396b09b3565118895c6e1794befd027db1842dc7fd33f3e74031e0ba74be72475df1
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild
new file mode 100644
index 000000000000..7a7a68e62676
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.11.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/robot_model"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
new file mode 100644
index 000000000000..5f4325158a53
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-1.12.13.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
new file mode 100644
index 000000000000..5f4325158a53
--- /dev/null
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/joint_state_publisher"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for setting and publishing joint state values for a given URDF"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${DEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/joint_state_publisher/metadata.xml b/dev-ros/joint_state_publisher/metadata.xml
new file mode 100644
index 000000000000..b74086ddd5fa
--- /dev/null
+++ b/dev-ros/joint_state_publisher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/joint_state_publisher</remote-id>
+ </upstream>
+</pkgmetadata>