summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/interval_intersection
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/Manifest6
-rw-r--r--dev-ros/interval_intersection/files/gcc6.patch31
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild30
-rw-r--r--dev-ros/interval_intersection/interval_intersection-9999.ebuild29
-rw-r--r--dev-ros/interval_intersection/metadata.xml11
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/Manifest b/dev-ros/interval_intersection/Manifest
new file mode 100644
index 000000000000..07093a72f594
--- /dev/null
+++ b/dev-ros/interval_intersection/Manifest
@@ -0,0 +1,6 @@
+AUX gcc6.patch 1465 SHA256 ec099d48480823e57ca5f5a155d259e3bb7b5c19d91fbcd319560c15b4e8cd73 SHA512 b2f5d80bce8c15b9636a57c56a83dc1b7f57463fe398b67436584e9790e6548b600c92b2921c624c3eafb590565db7eb17518b748dfd8d2bb440501e9e2c885d WHIRLPOOL 9492a71d0f0d73734a4a96ae3718cc52d5aa401cec13fe097ae20bfc922b8d749dca7ae81fbbc36556d194c86b7f041041ed5d1d6f500b1cf08c761612a6f2ac
+DIST calibration-0.10.14.tar.gz 112475 SHA256 1e65e6d8f793e7a27d1975ec3c4b63bf5249c7ce859dd11187258560901d1c77 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40 WHIRLPOOL 5c1ea989d438198044933927acfd7eb8426c9f5f253710ac63117b2a20c526acfea568f4b7b4f1930a43024bbcf4033f0f04c9e48108dc7e1cc629fb9e3c127f
+EBUILD interval_intersection-0.10.14.ebuild 799 SHA256 fedf867572321acda541a780a866974d684c964b110b94bc604535846463bb38 SHA512 bc7c81d318fc6d7d0c4534721837f8909472c3c0f959c777b612da39af43791688ee3987e69bacb2cef7e8b2484f270e01f21be92baaf23070196aa39892dc0d WHIRLPOOL 2c67f0e5fed353a2823e9f4d70a6a1dae69b96be722039d60a32fa8f02a3e02388f7bf158f9cbdfe219fab2ca191ae7a5ff21c53b9f9cb12be4ea1f8b67d748a
+EBUILD interval_intersection-9999.ebuild 762 SHA256 8acfa48026c06c214676e63cba2fd31881b9e24759b3ab959c29ee0b8583b087 SHA512 7d677353eeb5f99337aad8f0d8606ffe557d52b08874707bdeb8084fe8ae13fbe3844a21edd06bd39c339ac8ab7354de0b7397cfe07c0d4f1c3924a3941922cb WHIRLPOOL d5baa7b47185a91203f7672089792f0fe41ef3543221b682706025458fc160b19e4b292eed99ee4c980c6bfa705d03c6a493322d9e1b3f762db38ab0dfd33805
+MISC ChangeLog 1916 SHA256 f02c480cae6e47a1ea15748af10a723876d0be4289574779e94f8155280f066e SHA512 e56ba7a5dc42d09f5e2e17fb24837ba440bb43c6a2b9d724f777bf3db3a2b8d93c841cdf18f42dc1adf395d99f96a099adede0ac457f6995c34f1ab454a93933 WHIRLPOOL 1f22c9090378dca275bec504f86f30522647d9354f30205f40fd17c392b53bb8acb9f0b30c0000e8eceaee1d937d81646112d6c7e97284dfa68618dd4fbb6f86
+MISC metadata.xml 340 SHA256 678ba832ac98f8b0a18465056d6046bac6e86625e0d9c88087b65770e0a39bf7 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963 WHIRLPOOL 14899b95b028a1d21e6fc62ca4e22675cf9a742003656f7ecbe174f2c9d3ce252fa1c76ab6b8880153d92d7a4edb97028909be69b5f0992a9b6a1220694fb64f
diff --git a/dev-ros/interval_intersection/files/gcc6.patch b/dev-ros/interval_intersection/files/gcc6.patch
new file mode 100644
index 000000000000..632383629f66
--- /dev/null
+++ b/dev-ros/interval_intersection/files/gcc6.patch
@@ -0,0 +1,31 @@
+commit c23ddb86367fc43c2d15e08a452ad2dc1a62041b
+Author: Hodorgasm <nsane457@gmail.com>
+Date: Mon Sep 19 19:11:57 2016 -0400
+
+ Fix "stdlib.h: No such file or directory" errors in GCC-6
+
+ Including '-isystem /usr/include' breaks building with GCC-6.
+ See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=70129
+
+diff --git a/interval_intersection/CMakeLists.txt b/interval_intersection/CMakeLists.txt
+index 9bfd103..73bc0ac 100644
+--- a/interval_intersection/CMakeLists.txt
++++ b/interval_intersection/CMakeLists.txt
+@@ -4,7 +4,7 @@ project(interval_intersection)
+ find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED actionlib actionlib_msgs calibration_msgs geometry_msgs rosconsole roscpp roscpp_serialization rostime std_msgs)
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+
+ # generate the messages
+@@ -35,7 +35,7 @@ add_executable(interval_intersection_node src/interval_intersection_node.cpp)
+ target_link_libraries(interval_intersection_node ${PROJECT_NAME})
+ add_dependencies(interval_intersection_node calibration_msgs_gencpp)
+
+-include_directories(SYSTEM ${BOOST_INCLUDE_DIRS})
++include_directories(${BOOST_INCLUDE_DIRS})
+ add_executable(interval_intersection_action src/interval_intersection_action.cpp)
+ target_link_libraries(interval_intersection_action ${Boost_LIBRARIES}
+ ${catkin_LIBRARIES}
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
new file mode 100644
index 000000000000..e814990288f3
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/gcc6.patch" )
diff --git a/dev-ros/interval_intersection/interval_intersection-9999.ebuild b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
new file mode 100644
index 000000000000..bf87d040c0f6
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
diff --git a/dev-ros/interval_intersection/metadata.xml b/dev-ros/interval_intersection/metadata.xml
new file mode 100644
index 000000000000..660014a7883d
--- /dev/null
+++ b/dev-ros/interval_intersection/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/calibration</remote-id>
+ </upstream>
+</pkgmetadata>