summaryrefslogtreecommitdiff
path: root/dev-ros/imu_processors
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/imu_processors
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/imu_processors')
-rw-r--r--dev-ros/imu_processors/Manifest6
-rw-r--r--dev-ros/imu_processors/imu_processors-0.2.1.ebuild23
-rw-r--r--dev-ros/imu_processors/imu_processors-0.2.2.ebuild23
-rw-r--r--dev-ros/imu_processors/imu_processors-9999.ebuild23
-rw-r--r--dev-ros/imu_processors/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-ros/imu_processors/Manifest b/dev-ros/imu_processors/Manifest
new file mode 100644
index 000000000000..717c95abbba1
--- /dev/null
+++ b/dev-ros/imu_processors/Manifest
@@ -0,0 +1,6 @@
+DIST imu_pipeline-0.2.1.tar.gz 7962 BLAKE2B 4af64db84fe96d70d2c61f8c16375bb28faac9c5630f3cad8c94ef9f87c5b17e302313a2511442b8c810e2ac589a733d6b333b2111b579c06559befaa5e9e1c6 SHA512 43c990e3b5a813661111f15bbaf6101794480de0f5bd9af663ce48ebbcf75ee79fa388cf228216427e7ffcbc575a317f3b0ee3ae5b8e6cca2cc0cab736c139e4
+DIST imu_pipeline-0.2.2.tar.gz 8080 BLAKE2B cdeeb7b95cca23aa7c30902b3be3daa34af222ff660058c1e57cf02b75008d4840b82cb52dbf7fa9a2968b2e41244fe7f1833429bd04280fdf68fb7fff2d240d SHA512 95913f3edec9af4d981d6034beb8932bba2e8a4d05a72c70c1bf2bcd5b85a9afa490e2916b6e4178e35b6a1967208999bfb697f5925ce12cae7e57fad2721f3f
+EBUILD imu_processors-0.2.1.ebuild 536 BLAKE2B e3fa445ab95374d77e9f11d0b1e1e690bc29698c30ea6431e7d2e3b5242b7a1e023149e3aef2c306ba54472f608e926f0f8ffff78aa0124948c947fb9ccf4949 SHA512 f3b9e557c9f8bfdffa68277b5a809bee86dbbd34420abe9fe70447c54fa3ce385e101904497437dfdf0d14bdca275783cb892b1a069eefe9f396b34b3e569331
+EBUILD imu_processors-0.2.2.ebuild 536 BLAKE2B 52d7f27a6f397075744915a445030425a12e46b284d083b32e934260eee129fa473673d2628d284343bbf78f1a356451f02165603cb238cd2a0074107dd80597 SHA512 619583a316723f8f0f90e5a3191ae221ac21103ff07a8380078a0b256c825d9d3437f5b6481c1a529b3d8410df6fc13eb9d88cb374210d6bb68178cee4909faa
+EBUILD imu_processors-9999.ebuild 536 BLAKE2B e3fa445ab95374d77e9f11d0b1e1e690bc29698c30ea6431e7d2e3b5242b7a1e023149e3aef2c306ba54472f608e926f0f8ffff78aa0124948c947fb9ccf4949 SHA512 f3b9e557c9f8bfdffa68277b5a809bee86dbbd34420abe9fe70447c54fa3ce385e101904497437dfdf0d14bdca275783cb892b1a069eefe9f396b34b3e569331
+MISC metadata.xml 341 BLAKE2B 25a24a32562bee0499af4b1e1a59341a7087ae303f179dc1f83b7b67c16f6fb6d9c835eafeaf6cd006e5ff9bae9d6ccc661ea2319656532436e4b6b093231f20 SHA512 37ef287b9a99e47b966f647c2ec1690bc6339f2f82047a1cefecd138ffe388ac2900c744999385c86dd9819c2664ac89b36ab64dcded0d2358aa703b16115761
diff --git a/dev-ros/imu_processors/imu_processors-0.2.1.ebuild b/dev-ros/imu_processors/imu_processors-0.2.1.ebuild
new file mode 100644
index 000000000000..4848998eaf36
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-0.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/imu_processors/imu_processors-0.2.2.ebuild b/dev-ros/imu_processors/imu_processors-0.2.2.ebuild
new file mode 100644
index 000000000000..2aa7070db8b7
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-0.2.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/imu_processors/imu_processors-9999.ebuild b/dev-ros/imu_processors/imu_processors-9999.ebuild
new file mode 100644
index 000000000000..4848998eaf36
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/imu_processors/metadata.xml b/dev-ros/imu_processors/metadata.xml
new file mode 100644
index 000000000000..4fa31f58d6b4
--- /dev/null
+++ b/dev-ros/imu_processors/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/imu_pipeline</remote-id>
+ </upstream>
+</pkgmetadata>