summaryrefslogtreecommitdiff
path: root/dev-ros/imu_processors/imu_processors-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/imu_processors/imu_processors-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/imu_processors/imu_processors-9999.ebuild')
-rw-r--r--dev-ros/imu_processors/imu_processors-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/imu_processors/imu_processors-9999.ebuild b/dev-ros/imu_processors/imu_processors-9999.ebuild
new file mode 100644
index 000000000000..4848998eaf36
--- /dev/null
+++ b/dev-ros/imu_processors/imu_processors-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Processors for sensor_msgs::Imu data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"