summaryrefslogtreecommitdiff
path: root/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild')
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
index d9eb91e64e14..6c1525c19499 100644
--- a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
KEYWORDS="~amd64"
@@ -9,7 +9,7 @@ ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+DESCRIPTION="Fuses angular velocities, accelerations, and magnetic readings from an IMU"
LICENSE="BSD"
SLOT="0"
IUSE=""
@@ -17,11 +17,13 @@ IUSE=""
RDEPEND="
dev-ros/message_filters
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
dev-libs/boost:=
"
DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
dev-ros/cmake_modules
"