summaryrefslogtreecommitdiff
path: root/dev-ros/image_cb_detector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ros/image_cb_detector
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/image_cb_detector')
-rw-r--r--dev-ros/image_cb_detector/Manifest6
-rw-r--r--dev-ros/image_cb_detector/files/c11.patch13
-rw-r--r--dev-ros/image_cb_detector/files/gcc6.patch13
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild32
-rw-r--r--dev-ros/image_cb_detector/image_cb_detector-9999.ebuild32
-rw-r--r--dev-ros/image_cb_detector/metadata.xml11
6 files changed, 0 insertions, 107 deletions
diff --git a/dev-ros/image_cb_detector/Manifest b/dev-ros/image_cb_detector/Manifest
deleted file mode 100644
index de4f43b1f7d0..000000000000
--- a/dev-ros/image_cb_detector/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX c11.patch 587 BLAKE2B 2cf07b3b5eebf9840bd45aa419283cc53e03dc45c5cf4eab6cd5894143983c7cb05146c9242c91ac105c90bba8d878ff8da4776629f04fc3f32b5290aa59fd87 SHA512 1ae09e987fb231400594019832f8a6d42ca1ebd07eafaca151d08812d8a4b62f95d4fadac0227c96d115c69da24bc3889f7d30af27000347ee000a937ae2b498
-AUX gcc6.patch 495 BLAKE2B 50ac60a74148e3e32b2a69750cad6d98ce2ecef22ed4462431821075f6e247290e28b8d57b58b4b86a7cb9600988a8e22ea2aa5508da6dd6ac85a93aac197ad1 SHA512 5b99edada624eabd4830997677ebb4916c6a9a3c631eead6ae723985e3ce5a0f3b77c484777182a34e727dba869181d11002ba38cfb49cf20eb0832aca67f6bb
-DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
-EBUILD image_cb_detector-0.10.14-r1.ebuild 933 BLAKE2B afb1d6def81a9a3ca97bb1beefbf761626ca7a671268bb41f5fe7ef56c86a02028143f34a0d95ad82fb461181a9458aa9f13e38b77ddfa5e48c25ed2d3ed5357 SHA512 a74f31fc57efb8c52cc67127f694cf1776257773b2b575cb3786ede25618453980c0688bf519bf63e34947e31ca3fbb24703dc7e5506e6962f1bd4999d2756a9
-EBUILD image_cb_detector-9999.ebuild 933 BLAKE2B afb1d6def81a9a3ca97bb1beefbf761626ca7a671268bb41f5fe7ef56c86a02028143f34a0d95ad82fb461181a9458aa9f13e38b77ddfa5e48c25ed2d3ed5357 SHA512 a74f31fc57efb8c52cc67127f694cf1776257773b2b575cb3786ede25618453980c0688bf519bf63e34947e31ca3fbb24703dc7e5506e6962f1bd4999d2756a9
-MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/image_cb_detector/files/c11.patch b/dev-ros/image_cb_detector/files/c11.patch
deleted file mode 100644
index bddbce93725f..000000000000
--- a/dev-ros/image_cb_detector/files/c11.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: image_cb_detector/src/rgbd_cb_detector_action.cpp
-===================================================================
---- image_cb_detector.orig/src/rgbd_cb_detector_action.cpp
-+++ image_cb_detector/src/rgbd_cb_detector_action.cpp
-@@ -143,7 +143,7 @@ public:
- for(size_t i = 0; i< features.image_points.size(); i++){
- geometry_msgs::Point pixel = features.image_points[i];
- float depth = *(depth_ptr+width*(unsigned int)pixel.y+(unsigned int)pixel.x);
-- if ( isnan(depth) )
-+ if ( std::isnan(depth) )
- {
- continue;
- }
diff --git a/dev-ros/image_cb_detector/files/gcc6.patch b/dev-ros/image_cb_detector/files/gcc6.patch
deleted file mode 100644
index af68c1e654ca..000000000000
--- a/dev-ros/image_cb_detector/files/gcc6.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: image_cb_detector/CMakeLists.txt
-===================================================================
---- image_cb_detector.orig/CMakeLists.txt
-+++ image_cb_detector/CMakeLists.txt
-@@ -24,7 +24,7 @@ catkin_package(INCLUDE_DIRS include
-
- # define some includes
- include_directories(include)
--include_directories(SYSTEM ${Boost_INCLUDE_DIRS}
-+include_directories(${Boost_INCLUDE_DIRS}
- ${catkin_INCLUDE_DIRS}
- ${OpenCV_INCLUDE_DIRS}
- )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild b/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
deleted file mode 100644
index 8b96da0e6b06..000000000000
--- a/dev-ros/image_cb_detector/image_cb_detector-0.10.14-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/calibration"
-CATKIN_HAS_MESSAGES=yes
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/actionlib_msgs dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Extracts checkerboard corners from ROS images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/actionlib[${PYTHON_USEDEP}]
- dev-ros/cv_bridge[${PYTHON_USEDEP}]
- media-libs/opencv:=
- dev-ros/image_transport
- dev-ros/message_filters
- dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild b/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
deleted file mode 100644
index 8b96da0e6b06..000000000000
--- a/dev-ros/image_cb_detector/image_cb_detector-9999.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-ROS_REPO_URI="https://github.com/ros-perception/calibration"
-CATKIN_HAS_MESSAGES=yes
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/actionlib_msgs dev-ros/std_msgs"
-
-inherit ros-catkin
-
-DESCRIPTION="Extracts checkerboard corners from ROS images"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/actionlib[${PYTHON_USEDEP}]
- dev-ros/cv_bridge[${PYTHON_USEDEP}]
- media-libs/opencv:=
- dev-ros/image_transport
- dev-ros/message_filters
- dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-libs/boost:=[threads]
-"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/gcc6.patch" "${FILESDIR}/c11.patch" )
diff --git a/dev-ros/image_cb_detector/metadata.xml b/dev-ros/image_cb_detector/metadata.xml
deleted file mode 100644
index 660014a7883d..000000000000
--- a/dev-ros/image_cb_detector/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros-perception/calibration</remote-id>
- </upstream>
-</pkgmetadata>