summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation_core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/hector_pose_estimation_core
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/hector_pose_estimation_core')
-rw-r--r--dev-ros/hector_pose_estimation_core/Manifest7
-rw-r--r--dev-ros/hector_pose_estimation_core/files/eigen.patch13
-rw-r--r--dev-ros/hector_pose_estimation_core/files/gcc6.patch35
-rw-r--r--dev-ros/hector_pose_estimation_core/files/includes.patch12
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild29
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild28
-rw-r--r--dev-ros/hector_pose_estimation_core/metadata.xml11
7 files changed, 135 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation_core/Manifest b/dev-ros/hector_pose_estimation_core/Manifest
new file mode 100644
index 000000000000..dcb8906000fc
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/Manifest
@@ -0,0 +1,7 @@
+AUX eigen.patch 892 BLAKE2B 68b8df118a6d2a644ee1bd8407144f50fc270bc767984093e146cf537799e9dee11db670006c5cf467bd98c3ffd3f6c2cb1db6c9e8ab81618bb6a29489cf6bf1 SHA512 302e4fecdfb674b66d737d93d427b61e5fb00932469190c3b631c6e2fc4647c2622591ec83975b42d9e1bb71b70f8d942c3fe4101d9927ce2c909c1baef38d35
+AUX gcc6.patch 1597 BLAKE2B 9df1a297741dbcb957ef9bc910332e237a84ffcef87547f0d29573c4a3aa4255a0d65fb0f2eb7b404a8c9ecf4441b2a9dee60dd1d832b7690baceb2b1ae39951 SHA512 7ef60982584cf5021d9a8c084492de84d54dc0150ad0cd5acfc9c709641935c5a9ee649e5546cae6d2da061a0e3a887e5f1ea97e1fa3848ad9dd4de7ff3ee817
+AUX includes.patch 562 BLAKE2B 2a6bf54f37cf5275014d2f69428568eb4e5b5c967c88129c3fde9ff89f0bcf3ab26abd2c538d5ea5977182393e189ab156bb9a24446df822106de72cf7a2bd1f SHA512 a689645403095ef37be5a259d593ee8e6f412a77a0997b5025c85c5c9f09ef9bce622d4afccc58e9baed89576db9280d615f4a0df2eee22a18ee832f12e786a8
+DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
+EBUILD hector_pose_estimation_core-0.3.0-r1.ebuild 803 BLAKE2B 55419c38502f1264a29b5932f2aa00e467730d6b92ab66ea1cc3067aa2cb70851d88ef0439b77e5e9374887da338c151d5bcf615536c4e980fdc321008ce5124 SHA512 59a73b76930f02107c3308545ebce88ce5b1198b46803858066244e493997bfdfe2ede29ee6bb3603b31b793e694f56491cc792d4bae9eb5295e301aeba83d58
+EBUILD hector_pose_estimation_core-9999.ebuild 711 BLAKE2B e1455cf2d4af72fe418a0bbfb386de51c867af6bdb4dba92efaf12a8204f9fa239c2bccf7a9b40a2f63432f469040c073d18907b409f2d7b085693d32e7c4384 SHA512 8b67fb9ce6030102d7cc9b82db7f0921bae58770e272b1a8527e60f3e9576f71f53523ffa0fb563bf348fda33eadcd0c56353e7c5f99467357d132a334f45e6c
+MISC metadata.xml 354 BLAKE2B 8fa87680be83a7fc421afc00fa7e203bd512c42324cee5ce59f08a6acdfacdd09a8427e547982ccff17253589708a0556e51420188c3639ab638df4994e4edb7 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420
diff --git a/dev-ros/hector_pose_estimation_core/files/eigen.patch b/dev-ros/hector_pose_estimation_core/files/eigen.patch
new file mode 100644
index 000000000000..b58bb9e8ca3d
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/eigen.patch
@@ -0,0 +1,13 @@
+Index: hector_pose_estimation_core/src/measurements/poseupdate.cpp
+===================================================================
+--- hector_pose_estimation_core.orig/src/measurements/poseupdate.cpp
++++ hector_pose_estimation_core/src/measurements/poseupdate.cpp
+@@ -382,7 +382,7 @@ double PoseUpdate::updateInternal(State
+ ROS_DEBUG_STREAM_NAMED("poseupdate", "alpha = " << alpha << ", beta = " << beta);
+
+ if (max_error > 0.0) {
+- double error2 = error.transpose() * Ix * (Ix + Iy).inverse() * Iy * error;
++ double error2 = error.transpose().dot( Ix * (Ix + Iy).inverse() * Iy * error);
+ if (error2 > max_error * max_error) {
+ if (!jump_on_max_error_ || !jump_function) {
+ ROS_WARN_STREAM_NAMED("poseupdate", "Ignoring poseupdate for " << text << " as the error [ " << error.transpose() << " ], |error| = " << sqrt(error2) << " sigma exceeds max_error!");
diff --git a/dev-ros/hector_pose_estimation_core/files/gcc6.patch b/dev-ros/hector_pose_estimation_core/files/gcc6.patch
new file mode 100644
index 000000000000..42862915244b
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/gcc6.patch
@@ -0,0 +1,35 @@
+Index: hector_pose_estimation_core/include/hector_pose_estimation/input.h
+===================================================================
+--- hector_pose_estimation_core.orig/include/hector_pose_estimation/input.h
++++ hector_pose_estimation_core/include/hector_pose_estimation/input.h
+@@ -79,7 +79,7 @@ public:
+ return *variance_;
+ }
+
+- virtual bool hasVariance() const { return variance_; }
++ virtual bool hasVariance() const { return variance_ != NULL; }
+ virtual Variance const &getVariance() { if (!variance_) variance_.reset(new Variance); return *variance_; }
+ virtual Variance const &getVariance() const { return *variance_; }
+ virtual Variance& variance() { if (!variance_) variance_.reset(new Variance); return *variance_; }
+Index: hector_pose_estimation_core/src/system/imu_model.cpp
+===================================================================
+--- hector_pose_estimation_core.orig/src/system/imu_model.cpp
++++ hector_pose_estimation_core/src/system/imu_model.cpp
+@@ -51,7 +51,7 @@ GyroModel::~GyroModel()
+ bool GyroModel::init(PoseEstimation& estimator, System &system, State& state)
+ {
+ bias_ = state.addSubState<3,3>(this, system.getName() + "_bias");
+- return bias_;
++ return bias_ != NULL;
+ }
+
+ void GyroModel::getPrior(State &state)
+@@ -113,7 +113,7 @@ AccelerometerModel::~AccelerometerModel(
+ bool AccelerometerModel::init(PoseEstimation& estimator, System &system, State& state)
+ {
+ bias_ = state.addSubState<3,3>(this, system.getName() + "_bias");
+- return bias_;
++ return bias_ != NULL;
+ }
+
+ void AccelerometerModel::getPrior(State &state)
diff --git a/dev-ros/hector_pose_estimation_core/files/includes.patch b/dev-ros/hector_pose_estimation_core/files/includes.patch
new file mode 100644
index 000000000000..0188d027ed9d
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/includes.patch
@@ -0,0 +1,12 @@
+Index: hector_localization-0.3.0/hector_pose_estimation_core/include/hector_pose_estimation/state.h
+===================================================================
+--- hector_localization-0.3.0.orig/hector_pose_estimation_core/include/hector_pose_estimation/state.h
++++ hector_localization-0.3.0/hector_pose_estimation_core/include/hector_pose_estimation/state.h
+@@ -29,6 +29,7 @@
+ #ifndef HECTOR_POSE_ESTIMATION_STATE_H
+ #define HECTOR_POSE_ESTIMATION_STATE_H
+
++#include <vector>
+ #include <hector_pose_estimation/types.h>
+
+ #include <boost/function.hpp>
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..8c95893cad5a
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostime
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
+PATCHES=( "${FILESDIR}/includes.patch" "${FILESDIR}/gcc6.patch" "${FILESDIR}/eigen.patch" )
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
new file mode 100644
index 000000000000..8c1ce15dafe8
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extended Kalman Filter (EKF) that estimates the 6DOF pose of the robot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostime
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_pose_estimation_core/metadata.xml b/dev-ros/hector_pose_estimation_core/metadata.xml
new file mode 100644
index 000000000000..ee6ea29b2d58
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
+ </upstream>
+</pkgmetadata>