summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/hector_pose_estimation
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/hector_pose_estimation')
-rw-r--r--dev-ros/hector_pose_estimation/Manifest4
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild28
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild28
-rw-r--r--dev-ros/hector_pose_estimation/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation/Manifest b/dev-ros/hector_pose_estimation/Manifest
new file mode 100644
index 000000000000..8471aba76525
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/Manifest
@@ -0,0 +1,4 @@
+DIST hector_localization-0.3.0.tar.gz 73656 BLAKE2B 8e895c760974f8707eb174b3b385f03f07f93f89b470d88140f1134a3cb9fb8e67e65a86484b702dbaed09e4d614f4c6759f1e08b536385f86ec15dc3db6a644 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df
+EBUILD hector_pose_estimation-0.3.0-r1.ebuild 711 BLAKE2B 67d3ab3da4f47e0b7784bc578f31983b5dca9c09b344d88c0c1f42355de74a126a5339b6179b8e43dc73693c8fe89e5384df3080bc742a05090f5ab250511834 SHA512 abeb93640c11c0d1359ce0e84adc9ce43b42461b259225f39c2189688a164ebc7d4f76195ca89c9e77a545f21b4dfd1e83ac13b07c657c063f86f95ca0a4da9b
+EBUILD hector_pose_estimation-9999.ebuild 711 BLAKE2B 67d3ab3da4f47e0b7784bc578f31983b5dca9c09b344d88c0c1f42355de74a126a5339b6179b8e43dc73693c8fe89e5384df3080bc742a05090f5ab250511834 SHA512 abeb93640c11c0d1359ce0e84adc9ce43b42461b259225f39c2189688a164ebc7d4f76195ca89c9e77a545f21b4dfd1e83ac13b07c657c063f86f95ca0a4da9b
+MISC metadata.xml 354 BLAKE2B 8fa87680be83a7fc421afc00fa7e203bd512c42324cee5ce59f08a6acdfacdd09a8427e547982ccff17253589708a0556e51420188c3639ab638df4994e4edb7 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..7cc3dd4e6490
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
new file mode 100644
index 000000000000..7cc3dd4e6490
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_pose_estimation/metadata.xml b/dev-ros/hector_pose_estimation/metadata.xml
new file mode 100644
index 000000000000..ee6ea29b2d58
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
+ </upstream>
+</pkgmetadata>