summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/hector_pose_estimation
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/hector_pose_estimation')
-rw-r--r--dev-ros/hector_pose_estimation/Manifest5
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0.ebuild27
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild27
-rw-r--r--dev-ros/hector_pose_estimation/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation/Manifest b/dev-ros/hector_pose_estimation/Manifest
new file mode 100644
index 000000000000..7ac40e07dce0
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/Manifest
@@ -0,0 +1,5 @@
+DIST hector_localization-0.3.0.tar.gz 73656 SHA256 36dd8dba4496e50df65505707ade089c1e2dfe1855b78081f68706a104c38326 SHA512 5763a98247754b021631c894d44172d7c215d81f556760578f585febf2248da8dfcf10c6f1430cff47800778d39a79ab31a59916ad13c6d5ecf8a17eeac4e8df WHIRLPOOL 26ef7ff7b5011b81349448954bec84f70841d543668d43e4b50783e48580eb2632ba8713d3df1a75d5e1f2ada7fd60d8dab551cf4392ea4effc49a4272c4855e
+EBUILD hector_pose_estimation-0.3.0.ebuild 684 SHA256 56f118dd6bec921231ebab6cf3f0b02e4dd7192332e4c379206ad827c9564c13 SHA512 49aaac2357c322d0c257b041b80cb98523f65a8ea483ecf475c448023fbea46687d5cc5069f7e6ed413eaa48e6e431a8db7215c07303979118fca656864a501b WHIRLPOOL 6d86418041b47e9d76bb45678e419807b9821624afd5b1179c0dbeb745d0e355888d06fab2451696673ed66998c0709e495dd8d7f14a741e5d218f3ca843498a
+EBUILD hector_pose_estimation-9999.ebuild 684 SHA256 56f118dd6bec921231ebab6cf3f0b02e4dd7192332e4c379206ad827c9564c13 SHA512 49aaac2357c322d0c257b041b80cb98523f65a8ea483ecf475c448023fbea46687d5cc5069f7e6ed413eaa48e6e431a8db7215c07303979118fca656864a501b WHIRLPOOL 6d86418041b47e9d76bb45678e419807b9821624afd5b1179c0dbeb745d0e355888d06fab2451696673ed66998c0709e495dd8d7f14a741e5d218f3ca843498a
+MISC ChangeLog 1787 SHA256 433600f602aa7fd5b1781694207265e92d70f3b5d77fe5f324e590a63311e169 SHA512 ac3c38642a1987ebe9486e845f4df9b857665aea25d911c9d47200aa721fcb310a35f17474b7192290ee2111203a87306ab102af7b61b8edd4f9e30ab9b96f39 WHIRLPOOL a7752cad923443177c2ce39b9152e46ac17aaa70dd720cc33fefe91a9ce29adc15e6b4fa649c489748f8af0ff1bdb137e919dd41ccca88353d3d6de93a58d9af
+MISC metadata.xml 354 SHA256 7fbc9041a508b4280e3ff8c43938f8d673a12df4669e2d771792ae2380515cd5 SHA512 5efea6ff063bdb92ca5c0c45cbc4c9cc110d4ed800b8631259abdffb771abb183594d9e72920e0daf9948c909a69ab564b70fed83bb2a0a879d5712f3c608420 WHIRLPOOL 06c01e937faa41d66f13b986cdcb1f0b4d92659c869909d3c8d6864cc2f7b6e25d03240302df7fe5270e2e50cf6a0ce901db8f4d79e032548bf20897db83b824
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0.ebuild
new file mode 100644
index 000000000000..ff5460914801
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-libs/boost:=
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
new file mode 100644
index 000000000000..ff5460914801
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-libs/boost:=
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_pose_estimation/metadata.xml b/dev-ros/hector_pose_estimation/metadata.xml
new file mode 100644
index 000000000000..ee6ea29b2d58
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_localization</remote-id>
+ </upstream>
+</pkgmetadata>