summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/hector_mapping
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/hector_mapping')
-rw-r--r--dev-ros/hector_mapping/Manifest4
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild28
-rw-r--r--dev-ros/hector_mapping/hector_mapping-9999.ebuild28
-rw-r--r--dev-ros/hector_mapping/metadata.xml11
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/Manifest b/dev-ros/hector_mapping/Manifest
new file mode 100644
index 000000000000..b420336c5fad
--- /dev/null
+++ b/dev-ros/hector_mapping/Manifest
@@ -0,0 +1,4 @@
+DIST hector_slam-0.3.5.tar.gz 66002 BLAKE2B 6e370fedf49b450cd3dec77eb7a197cc13796d787c41a72d5bdf918661728e96ff9e388ab1f2c5cf64c13ff6e94e058fc4c8ba176307b63cc51b892c0183dd54 SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1
+EBUILD hector_mapping-0.3.5.ebuild 715 BLAKE2B 5ab263a2b9cd0180955a66cadc42006a39cc54cfd23c7ae791e4eac4921feea2f73cab8f5ec309656df395a25dc2eebd434f0c037e13cdc5f3eb61dc401d3398 SHA512 038c94df68ec418a43c1779f3c9cb6097ee5bb937370cf39cb34b18d08d31d69451a9721466d4e8e0e016db1aa7abaa70cd99a12a9f591562268dca5185b9086
+EBUILD hector_mapping-9999.ebuild 715 BLAKE2B 5ab263a2b9cd0180955a66cadc42006a39cc54cfd23c7ae791e4eac4921feea2f73cab8f5ec309656df395a25dc2eebd434f0c037e13cdc5f3eb61dc401d3398 SHA512 038c94df68ec418a43c1779f3c9cb6097ee5bb937370cf39cb34b18d08d31d69451a9721466d4e8e0e016db1aa7abaa70cd99a12a9f591562268dca5185b9086
+MISC metadata.xml 346 BLAKE2B 2c19759ef75680fbdf13a2782c7ab61ce35df604fdc577f03e538cf599ab5bdd8c18c3abb14411c19148d96b086efd7f1ce4c851243085ecf5a429c20d0eca88 SHA512 7e8f72ba74709122f67811e4d0945757dd30c8bc266d95198293260631d0d0eb2063d19996e6dffa4e0184f5bda1e3bd44b6bee6956b58dcebc6919ff64199bb
diff --git a/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild b/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild
new file mode 100644
index 000000000000..2d1cf413d581
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/hector_mapping-9999.ebuild b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
new file mode 100644
index 000000000000..2d1cf413d581
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/metadata.xml b/dev-ros/hector_mapping/metadata.xml
new file mode 100644
index 000000000000..29147f0be960
--- /dev/null
+++ b/dev-ros/hector_mapping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
+ </upstream>
+</pkgmetadata>