summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/hector_mapping
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/hector_mapping')
-rw-r--r--dev-ros/hector_mapping/Manifest5
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild28
-rw-r--r--dev-ros/hector_mapping/hector_mapping-9999.ebuild28
-rw-r--r--dev-ros/hector_mapping/metadata.xml11
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/Manifest b/dev-ros/hector_mapping/Manifest
new file mode 100644
index 000000000000..aae51b8bf2e4
--- /dev/null
+++ b/dev-ros/hector_mapping/Manifest
@@ -0,0 +1,5 @@
+DIST hector_slam-0.3.5.tar.gz 66002 SHA256 80272696da825afbc21c5baa4477850f9df31174ae6bf65fe50519ff8eaf94bc SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1 WHIRLPOOL b6e1e9cd6f7610db25631ab8530d900306fb4eb3eb2e1cde844d965bea6882e53330cd237cc806c89090d32d361282ad0e23daccba8edea0020842b1b6a1e6fb
+EBUILD hector_mapping-0.3.5.ebuild 715 SHA256 ddd91c3542d80b450012dca2ef12bc483dbda68f7a46b867c69080d6d3e0d01d SHA512 038c94df68ec418a43c1779f3c9cb6097ee5bb937370cf39cb34b18d08d31d69451a9721466d4e8e0e016db1aa7abaa70cd99a12a9f591562268dca5185b9086 WHIRLPOOL ea1ff47d9e663bd60f8c32dbd0f929d31861e08b520f50f7c664edc07dbebf2a00ae9d65bb95be2c558aa572ad7c28e661829bdf972c0fb9a08ba3012629ef43
+EBUILD hector_mapping-9999.ebuild 715 SHA256 ddd91c3542d80b450012dca2ef12bc483dbda68f7a46b867c69080d6d3e0d01d SHA512 038c94df68ec418a43c1779f3c9cb6097ee5bb937370cf39cb34b18d08d31d69451a9721466d4e8e0e016db1aa7abaa70cd99a12a9f591562268dca5185b9086 WHIRLPOOL ea1ff47d9e663bd60f8c32dbd0f929d31861e08b520f50f7c664edc07dbebf2a00ae9d65bb95be2c558aa572ad7c28e661829bdf972c0fb9a08ba3012629ef43
+MISC ChangeLog 1938 SHA256 bb54f17e25bf8fb33e130c94263130cf651c385442ac8ea023827cd11a3dbd36 SHA512 65b00dde7899220b4d6e81a0d13588b70d96b573e89ec41f3856b92b96b94adda1917a40e9c7d78e5bae3f40f6b6280b797467dd26f756bbec9913427a03b801 WHIRLPOOL 026e1da64d69a971822f44e8f0aad18499fadd4a1c8c4dcdef1769c43600064a00af1dd6cf5fefbd234b591547c31d6ea8661d0432d1b02ea4889fe29e5fab24
+MISC metadata.xml 346 SHA256 0953075f18c36380a1fbb37e32534518d8522337587dc7e9ebde1a6aae7af6cd SHA512 7e8f72ba74709122f67811e4d0945757dd30c8bc266d95198293260631d0d0eb2063d19996e6dffa4e0184f5bda1e3bd44b6bee6956b58dcebc6919ff64199bb WHIRLPOOL c5efd1b8db9f7a98a9c80bd42be596251b890102705bc5520769d9431f7ac4c2e7ac5e09fe32997f23723d86a7e086d1e65c0151324f807b2a80bb42974389ff
diff --git a/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild b/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild
new file mode 100644
index 000000000000..2d1cf413d581
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.3.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/hector_mapping-9999.ebuild b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
new file mode 100644
index 000000000000..2d1cf413d581
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/metadata.xml b/dev-ros/hector_mapping/metadata.xml
new file mode 100644
index 000000000000..29147f0be960
--- /dev/null
+++ b/dev-ros/hector_mapping/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
+ </upstream>
+</pkgmetadata>