summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild')
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild b/dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..f3266ab2140e
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.5.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM that can be used without odometry and on platforms that exhibit roll/pitch"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads(+)]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"