summaryrefslogtreecommitdiff
path: root/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild')
-rw-r--r--dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild b/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
new file mode 100644
index 000000000000..d315b87686ab
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-0.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"