summaryrefslogtreecommitdiff
path: root/dev-ros/hector_geotiff_plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/hector_geotiff_plugins
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/hector_geotiff_plugins')
-rw-r--r--dev-ros/hector_geotiff_plugins/Manifest5
-rw-r--r--dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-0.3.5.ebuild21
-rw-r--r--dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-9999.ebuild21
-rw-r--r--dev-ros/hector_geotiff_plugins/metadata.xml11
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ros/hector_geotiff_plugins/Manifest b/dev-ros/hector_geotiff_plugins/Manifest
new file mode 100644
index 000000000000..c3ee7b57bcc8
--- /dev/null
+++ b/dev-ros/hector_geotiff_plugins/Manifest
@@ -0,0 +1,5 @@
+DIST hector_slam-0.3.5.tar.gz 66002 SHA256 80272696da825afbc21c5baa4477850f9df31174ae6bf65fe50519ff8eaf94bc SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1 WHIRLPOOL b6e1e9cd6f7610db25631ab8530d900306fb4eb3eb2e1cde844d965bea6882e53330cd237cc806c89090d32d361282ad0e23daccba8edea0020842b1b6a1e6fb
+EBUILD hector_geotiff_plugins-0.3.5.ebuild 480 SHA256 45ad1309df051c2026a5cb09a1bda448b865e801afd7b1b709b4b604841a4f78 SHA512 052069e9dd617088cd1bb727dbd4267d62bf5bab961763a148d24451fcb0e8c1b661b89fe0e54cd77f7c3382c3a40bd35bc022118407a989a53e0e0b688f770a WHIRLPOOL cb5a9d2b07bc766a64d1fef0e243360d5cb1d22857aa046dc297da90776bdb41c2566c2e01772506edbcba1fe15c8dfe2065d342db1ffe30c151082025ea1b68
+EBUILD hector_geotiff_plugins-9999.ebuild 480 SHA256 45ad1309df051c2026a5cb09a1bda448b865e801afd7b1b709b4b604841a4f78 SHA512 052069e9dd617088cd1bb727dbd4267d62bf5bab961763a148d24451fcb0e8c1b661b89fe0e54cd77f7c3382c3a40bd35bc022118407a989a53e0e0b688f770a WHIRLPOOL cb5a9d2b07bc766a64d1fef0e243360d5cb1d22857aa046dc297da90776bdb41c2566c2e01772506edbcba1fe15c8dfe2065d342db1ffe30c151082025ea1b68
+MISC ChangeLog 1787 SHA256 501b0c25f6303b3a7343b0bb8c47a10f1c1019b44508c1feafd6b81247052eec SHA512 751374352df80ac3b554cffe1be8f0b1d05fd3e118ded227a35f7a448cc97226ac635eadfa6eac538d5d308b40f72d4defce0468ca36b70de9e0c7d984837f7b WHIRLPOOL ff1c21cb8819152f1fcaf7200b19aaefb843ad82f03e21a9291707c43ac8ca391c57cc1fc2d2c009eda78ea5ba3217d8b54353ace3672b485c99fcd62f456fc0
+MISC metadata.xml 346 SHA256 0953075f18c36380a1fbb37e32534518d8522337587dc7e9ebde1a6aae7af6cd SHA512 7e8f72ba74709122f67811e4d0945757dd30c8bc266d95198293260631d0d0eb2063d19996e6dffa4e0184f5bda1e3bd44b6bee6956b58dcebc6919ff64199bb WHIRLPOOL c5efd1b8db9f7a98a9c80bd42be596251b890102705bc5520769d9431f7ac4c2e7ac5e09fe32997f23723d86a7e086d1e65c0151324f807b2a80bb42974389ff
diff --git a/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-0.3.5.ebuild b/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-0.3.5.ebuild
new file mode 100644
index 000000000000..5ad07adfe90f
--- /dev/null
+++ b/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-0.3.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugins that extend geotiff maps generated by hector_geotiff"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_geotiff
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-9999.ebuild b/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-9999.ebuild
new file mode 100644
index 000000000000..5ad07adfe90f
--- /dev/null
+++ b/dev-ros/hector_geotiff_plugins/hector_geotiff_plugins-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Plugins that extend geotiff maps generated by hector_geotiff"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_geotiff
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_geotiff_plugins/metadata.xml b/dev-ros/hector_geotiff_plugins/metadata.xml
new file mode 100644
index 000000000000..29147f0be960
--- /dev/null
+++ b/dev-ros/hector_geotiff_plugins/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
+ </upstream>
+</pkgmetadata>