summaryrefslogtreecommitdiff
path: root/dev-ros/hector_geotiff
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/hector_geotiff
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/hector_geotiff')
-rw-r--r--dev-ros/hector_geotiff/Manifest5
-rw-r--r--dev-ros/hector_geotiff/files/qt5.patch91
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-0.3.5-r2.ebuild33
-rw-r--r--dev-ros/hector_geotiff/hector_geotiff-9999.ebuild33
-rw-r--r--dev-ros/hector_geotiff/metadata.xml11
5 files changed, 173 insertions, 0 deletions
diff --git a/dev-ros/hector_geotiff/Manifest b/dev-ros/hector_geotiff/Manifest
new file mode 100644
index 000000000000..f8b82d41ac30
--- /dev/null
+++ b/dev-ros/hector_geotiff/Manifest
@@ -0,0 +1,5 @@
+AUX qt5.patch 3068 BLAKE2B 0ff205aab12c65b94ee200f770a30c3c34252237d536374f6684606f3cad170fd3045c80b8de021fea538d06f33c4495b5ecc10ebbac2d3a0d470be11cbf148f SHA512 26f6bbcd939f3119cbb6de237c1ba76703cb02ac6af22fa5c7ed1a9022b5c33c785d4891c12e14ddaee949b09283c0500984fd0455b3c69a4cae51192b8b98c1
+DIST hector_slam-0.3.5.tar.gz 66002 BLAKE2B 6e370fedf49b450cd3dec77eb7a197cc13796d787c41a72d5bdf918661728e96ff9e388ab1f2c5cf64c13ff6e94e058fc4c8ba176307b63cc51b892c0183dd54 SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1
+EBUILD hector_geotiff-0.3.5-r2.ebuild 806 BLAKE2B bc7c9512e331563c0fa96c6fab8691e4a58dced6e79cb73dbfe2a869b4dd894dd3346626f9d901512cbcd5519ec3f21230203fb5e020a681d80887a673d5934d SHA512 68ae0ad97a56b1a6b31a42c2e5d8eee6e03b288c59fb09dd96d5590429bb08ab3c905ffef8a5d84fb8e5f1059a5967185ea941145df3eb18ba9777d595ef5461
+EBUILD hector_geotiff-9999.ebuild 806 BLAKE2B bc7c9512e331563c0fa96c6fab8691e4a58dced6e79cb73dbfe2a869b4dd894dd3346626f9d901512cbcd5519ec3f21230203fb5e020a681d80887a673d5934d SHA512 68ae0ad97a56b1a6b31a42c2e5d8eee6e03b288c59fb09dd96d5590429bb08ab3c905ffef8a5d84fb8e5f1059a5967185ea941145df3eb18ba9777d595ef5461
+MISC metadata.xml 346 BLAKE2B 2c19759ef75680fbdf13a2782c7ab61ce35df604fdc577f03e538cf599ab5bdd8c18c3abb14411c19148d96b086efd7f1ce4c851243085ecf5a429c20d0eca88 SHA512 7e8f72ba74709122f67811e4d0945757dd30c8bc266d95198293260631d0d0eb2063d19996e6dffa4e0184f5bda1e3bd44b6bee6956b58dcebc6919ff64199bb
diff --git a/dev-ros/hector_geotiff/files/qt5.patch b/dev-ros/hector_geotiff/files/qt5.patch
new file mode 100644
index 000000000000..07b44ef23a13
--- /dev/null
+++ b/dev-ros/hector_geotiff/files/qt5.patch
@@ -0,0 +1,91 @@
+Index: hector_geotiff/CMakeLists.txt
+===================================================================
+--- hector_geotiff.orig/CMakeLists.txt
++++ hector_geotiff/CMakeLists.txt
+@@ -9,7 +9,7 @@ find_package(catkin REQUIRED COMPONENTS
+ ## System dependencies are found with CMake's conventions
+ # find_package(Boost REQUIRED COMPONENTS system)
+
+-find_package(Qt4 4.6 COMPONENTS QtCore QtGui REQUIRED)
++find_package(Qt5 5.7 COMPONENTS Core Gui Widgets REQUIRED)
+
+ # Find Eigen3 (from http://wiki.ros.org/jade/Migration)
+ find_package(Eigen3)
+@@ -24,8 +24,7 @@ else()
+ set(EIGEN3_INCLUDE_DIRS ${EIGEN3_INCLUDE_DIR})
+ endif()
+
+-include(${QT_USE_FILE})
+-
++add_compile_options(-fPIC)
+
+ ## Uncomment this if the package has a setup.py. This macro ensures
+ ## modules and global scripts declared therein get installed
+@@ -82,10 +81,14 @@ include_directories(include include/hect
+ include_directories(
+ ${catkin_INCLUDE_DIRS}
+ ${EIGEN3_INCLUDE_DIRS}
++ ${Qt5Core_INCLUDE_DIRS}
++ ${Qt5Widgets_INCLUDE_DIRS}
++ ${Qt5Gui_INCLUDE_DIRS}
+ )
+
+ add_library(geotiff_writer src/geotiff_writer/geotiff_writer.cpp)
+-target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${QT_LIBRARIES})
++target_link_libraries(geotiff_writer ${catkin_LIBRARIES} ${Qt5Core_LIBRARIES}
++ ${Qt5Widgets_LIBRARIES} ${Qt5Gui_LIBRARIES})
+ add_dependencies(geotiff_writer ${catkin_EXPORTED_TARGETS})
+
+ add_executable(geotiff_saver src/geotiff_saver.cpp)
+Index: hector_geotiff/include/hector_geotiff/geotiff_writer.h
+===================================================================
+--- hector_geotiff.orig/include/hector_geotiff/geotiff_writer.h
++++ hector_geotiff/include/hector_geotiff/geotiff_writer.h
+@@ -37,7 +37,7 @@
+ #include <nav_msgs/MapMetaData.h>
+
+ #include <QtGui/QImage>
+-#include <QtGui/QApplication>
++#include <QtWidgets/QApplication>
+ #include <QtGui/QFont>
+ #include <QtGui/QPen>
+
+Index: hector_geotiff/src/geotiff_node.cpp
+===================================================================
+--- hector_geotiff.orig/src/geotiff_node.cpp
++++ hector_geotiff/src/geotiff_node.cpp
+@@ -40,7 +40,7 @@
+
+ #include <Eigen/Geometry>
+
+-#include <QtGui/QApplication>
++#include <QtWidgets/QApplication>
+
+ #include <hector_map_tools/HectorMapTools.h>
+
+Index: hector_geotiff/src/geotiff_saver.cpp
+===================================================================
+--- hector_geotiff.orig/src/geotiff_saver.cpp
++++ hector_geotiff/src/geotiff_saver.cpp
+@@ -34,7 +34,7 @@
+
+ #include <Eigen/Geometry>
+
+-#include <QtGui/QApplication>
++#include <QtWidgets/QApplication>
+
+ #include <hector_map_tools/HectorMapTools.h>
+
+Index: hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
+===================================================================
+--- hector_geotiff.orig/src/geotiff_writer/geotiff_writer.cpp
++++ hector_geotiff/src/geotiff_writer/geotiff_writer.cpp
+@@ -31,7 +31,7 @@
+
+ #include <QtGui/QPainter>
+ #include <QtGui/QImageWriter>
+-#include <QtGui/QApplication>
++#include <QtWidgets/QApplication>
+ #include <QtCore/QFile>
+ //#include <QtCore/QDateTime>
+ #include <QtCore/QTime>
diff --git a/dev-ros/hector_geotiff/hector_geotiff-0.3.5-r2.ebuild b/dev-ros/hector_geotiff/hector_geotiff-0.3.5-r2.ebuild
new file mode 100644
index 000000000000..1bc71fd4e8be
--- /dev/null
+++ b/dev-ros/hector_geotiff/hector_geotiff-0.3.5-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_map_tools
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
+
+PATCHES=( "${FILESDIR}/qt5.patch" )
diff --git a/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild b/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
new file mode 100644
index 000000000000..1bc71fd4e8be
--- /dev/null
+++ b/dev-ros/hector_geotiff/hector_geotiff-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Node to save occupancy grid map, robot trajectory and object of interest data to GeoTiff images"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_map_tools
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
+
+PATCHES=( "${FILESDIR}/qt5.patch" )
diff --git a/dev-ros/hector_geotiff/metadata.xml b/dev-ros/hector_geotiff/metadata.xml
new file mode 100644
index 000000000000..29147f0be960
--- /dev/null
+++ b/dev-ros/hector_geotiff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
+ </upstream>
+</pkgmetadata>