summaryrefslogtreecommitdiff
path: root/dev-ros/global_planner
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/global_planner
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/global_planner')
-rw-r--r--dev-ros/global_planner/Manifest6
-rw-r--r--dev-ros/global_planner/global_planner-1.15.1-r1.ebuild30
-rw-r--r--dev-ros/global_planner/global_planner-1.15.2.ebuild30
-rw-r--r--dev-ros/global_planner/global_planner-9999.ebuild30
-rw-r--r--dev-ros/global_planner/metadata.xml11
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-ros/global_planner/Manifest b/dev-ros/global_planner/Manifest
new file mode 100644
index 000000000000..771cd83830bd
--- /dev/null
+++ b/dev-ros/global_planner/Manifest
@@ -0,0 +1,6 @@
+DIST navigation-1.15.1.tar.gz 346480 BLAKE2B 29f9a0b6f2c62bd21a7cb87a64b490c845bb7db4af338fd094744abb22402df7eedc8c164b64f93f2d67dabaff99ca3b946b45e93173bed74834d9e3668726ad SHA512 25c5093bf7acca9d15d46bb2d0ae7e4ce0fa45f18b32d1626668dcbd33732317e8535b978e7225d86391472c517f05acb7736f31a7c511c8736ab8a22c7af4b0
+DIST navigation-1.15.2.tar.gz 348985 BLAKE2B 866779425828b1e4c3a044654ae41f33643646ca70cf6841f23bce265add2c420bf0934a41a6b29fa65fc421228a31dc15e9fb0f6cc4295ce12adbbb627b43d4 SHA512 582422756b31b4d83e929e3c723e7205e772b9775fcf618c9bd5d3c54af1f20e9bc8a0143626750c0c3cffeb0cbea8f8706b7e66f62dc037cfe12b05f23ee142
+EBUILD global_planner-1.15.1-r1.ebuild 665 BLAKE2B 2f62de5934ed9a91e6a1e56e8028e2bb09e3166688530461b25cb9a3de23213bcd80b39c8c7ecaffd48b848f6cbaa79d429fabc344cb402e7ea1e1ab0df70ce6 SHA512 12c07e61b53c227e1ba6b4d8866a9e2addaac4bc156b7d4cb5520b07aeb0726f7a7b492cc222f9152d341de11a0f5fc2f9fef600b539ea4227afb2b37ab506a7
+EBUILD global_planner-1.15.2.ebuild 665 BLAKE2B 63ee38169ee7c4305119341480e3cb7e654fa060a1f7ef7e0d3260e3f116027cea6810d8e5c1ed90e7df16dc989af05a00a1fe4eb3a8ccbdd1ccb9525485b21a SHA512 695a3bc09081066c1535a42fca547b0367b3c0ebcdba1ba0a0a6e904353ad723d07a9762370103e9c16071b44f8ff5ed2ccefa1536d777097c78efa673516f7b
+EBUILD global_planner-9999.ebuild 665 BLAKE2B 2f62de5934ed9a91e6a1e56e8028e2bb09e3166688530461b25cb9a3de23213bcd80b39c8c7ecaffd48b848f6cbaa79d429fabc344cb402e7ea1e1ab0df70ce6 SHA512 12c07e61b53c227e1ba6b4d8866a9e2addaac4bc156b7d4cb5520b07aeb0726f7a7b492cc222f9152d341de11a0f5fc2f9fef600b539ea4227afb2b37ab506a7
+MISC metadata.xml 337 BLAKE2B ecfbf3d0b63a1b876065d04b3d52daa0442e3bcaf060836731012a1e698b3aea06ff292d892035feb2fb0fc257d6d8462d013ccc67f2650177c9cdba4d051d44 SHA512 f5df7464100fa15a3d2ad11cc620007500a5cb5ea7be67ac45819a541dd4ae53ce476231d475acf4dfe7e7bf0c31281325dc4e003867d1cc01a29353bb5ea09e
diff --git a/dev-ros/global_planner/global_planner-1.15.1-r1.ebuild b/dev-ros/global_planner/global_planner-1.15.1-r1.ebuild
new file mode 100644
index 000000000000..795f804d8ce5
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.15.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/global_planner/global_planner-1.15.2.ebuild b/dev-ros/global_planner/global_planner-1.15.2.ebuild
new file mode 100644
index 000000000000..5e101fb3111b
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.15.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/global_planner/global_planner-9999.ebuild b/dev-ros/global_planner/global_planner-9999.ebuild
new file mode 100644
index 000000000000..795f804d8ce5
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/global_planner/metadata.xml b/dev-ros/global_planner/metadata.xml
new file mode 100644
index 000000000000..7408fdf7047f
--- /dev/null
+++ b/dev-ros/global_planner/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/navigation</remote-id>
+ </upstream>
+</pkgmetadata>