summaryrefslogtreecommitdiff
path: root/dev-ros/geodesy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/geodesy
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/geodesy')
-rw-r--r--dev-ros/geodesy/Manifest5
-rw-r--r--dev-ros/geodesy/geodesy-0.5.2.ebuild34
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild34
-rw-r--r--dev-ros/geodesy/metadata.xml11
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-ros/geodesy/Manifest b/dev-ros/geodesy/Manifest
new file mode 100644
index 000000000000..e787e2234060
--- /dev/null
+++ b/dev-ros/geodesy/Manifest
@@ -0,0 +1,5 @@
+DIST geographic_info-0.5.2.tar.gz 27336 SHA256 8e5a6b8c63aae9d97a511034536c295f4229e93cc40e60988464dfc591f8564b SHA512 8b512399ef61ebfb9816c613ed4fcde23ec52a9b4bbd1bb7268c8ec7fe03b1a157435fef17b8af72fdf88ce6ed0b9130473183402e0875a25eac0ac46df0d00d WHIRLPOOL c26f0a8fc34eadbcc5fcba70631d539661728a009849841583f69bf72e96bac098da590fa8ae457663124864ede7e33187cbab8e018234ddc8a695466d0dacd9
+EBUILD geodesy-0.5.2.ebuild 922 SHA256 07d90fefc54acb929ec4bbd49bbc2e8c5c85191512d91c26add08044eb9867e3 SHA512 f6bfc50f7a3a6ee2adc0d289b8c228d6ef6a5b81cbb871aa2bc5eb199dc3279ac31dcb53ee21024e98eab14f6a9192c8d3043dfee53ce3a686955770361105a6 WHIRLPOOL 1b328b8eb7ac3cc10e0bfef1a5326413578793357c2c4745bbc4d4a52952860d5a966897d22ffaf2fd03ced5354bdbe2f7e289c85c02b094e20949fdc7f1441d
+EBUILD geodesy-9999.ebuild 922 SHA256 07d90fefc54acb929ec4bbd49bbc2e8c5c85191512d91c26add08044eb9867e3 SHA512 f6bfc50f7a3a6ee2adc0d289b8c228d6ef6a5b81cbb871aa2bc5eb199dc3279ac31dcb53ee21024e98eab14f6a9192c8d3043dfee53ce3a686955770361105a6 WHIRLPOOL 1b328b8eb7ac3cc10e0bfef1a5326413578793357c2c4745bbc4d4a52952860d5a966897d22ffaf2fd03ced5354bdbe2f7e289c85c02b094e20949fdc7f1441d
+MISC ChangeLog 1277 SHA256 a09ea1874e059a274eed2ed4b843d99586642a076b46d83a261cb38f864d9a64 SHA512 848bdf86e254b76993a01e868a7fdbe9d13fc5db930acc68fdec384a5ce00ce104b8626e0a6816b528df838b0d0bc7ffa6a2e68924a20b363ba91ec0ec191dbe WHIRLPOOL 3c2f66e2f88ea447054ae005da0a151bbb06e6f3a39d223dca2a3e6d8321984772a2b787ea5a63260de828cffd8725296485806569b783dc0b0f18463b0250e1
+MISC metadata.xml 349 SHA256 93967a3593a3d501ac13f435444743679ea2bedc0dd4e49840fc10f66b724f03 SHA512 453f7929a678908957bfde47ef0816a11162200a6b5541850320d874b3419155c4efebae51ef2d1b542f73bb4dcb319fdd93098817819cad2a9cb74adf008918 WHIRLPOOL 58434c9f2d4836bff1132f447ac89b5b034935de0403bc186be1c0f5c9c46bf43bad4beca9705a7c873273188f96bad93a2136cdb3b96616b9185f80daac16f1
diff --git a/dev-ros/geodesy/geodesy-0.5.2.ebuild b/dev-ros/geodesy/geodesy-0.5.2.ebuild
new file mode 100644
index 000000000000..ea8aaeb6424f
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-0.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
new file mode 100644
index 000000000000..ea8aaeb6424f
--- /dev/null
+++ b/dev-ros/geodesy/geodesy-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-geographic-info/geographic_info"
+VER_PREFIX=geographic_info-
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ interfaces for manipulating geodetic coordinates"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/angles
+ dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/unique_id
+ dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
diff --git a/dev-ros/geodesy/metadata.xml b/dev-ros/geodesy/metadata.xml
new file mode 100644
index 000000000000..ef3ec24a24af
--- /dev/null
+++ b/dev-ros/geodesy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-geographic-info/geographic_info</remote-id>
+ </upstream>
+</pkgmetadata>