summaryrefslogtreecommitdiff
path: root/dev-ros/genpy/genpy-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/genpy/genpy-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/genpy/genpy-9999.ebuild')
-rw-r--r--dev-ros/genpy/genpy-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-ros/genpy/genpy-9999.ebuild b/dev-ros/genpy/genpy-9999.ebuild
index 29c86a165741..a5796a02b2e9 100644
--- a/dev-ros/genpy/genpy-9999.ebuild
+++ b/dev-ros/genpy/genpy-9999.ebuild
@@ -9,16 +9,18 @@ KEYWORDS="~amd64 ~arm"
inherit ros-catkin
DESCRIPTION="Python ROS message and service generators"
-HOMEPAGE="http://wiki.ros.org/genpy"
+HOMEPAGE="https://wiki.ros.org/genpy"
LICENSE="BSD"
SLOT="0/${PV}"
IUSE=""
-RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)
"
PATCHES=( "${FILESDIR}/yaml.patch" )