summaryrefslogtreecommitdiff
path: root/dev-ros/genmsg/genmsg-0.5.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ros/genmsg/genmsg-0.5.12.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ros/genmsg/genmsg-0.5.12.ebuild')
-rw-r--r--dev-ros/genmsg/genmsg-0.5.12.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-ros/genmsg/genmsg-0.5.12.ebuild b/dev-ros/genmsg/genmsg-0.5.12.ebuild
new file mode 100644
index 000000000000..b4480e2c242a
--- /dev/null
+++ b/dev-ros/genmsg/genmsg-0.5.12.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/genmsg"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Python library for generating ROS message and service data structures for various languages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"