summaryrefslogtreecommitdiff
path: root/dev-ros/genlisp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-ros/genlisp
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-ros/genlisp')
-rw-r--r--dev-ros/genlisp/Manifest2
-rw-r--r--dev-ros/genlisp/genlisp-0.4.17.ebuild18
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/genlisp/Manifest b/dev-ros/genlisp/Manifest
index 105310f15999..9238626966d6 100644
--- a/dev-ros/genlisp/Manifest
+++ b/dev-ros/genlisp/Manifest
@@ -1,4 +1,6 @@
DIST genlisp-0.4.16.tar.gz 10059 BLAKE2B c6833f5af7b9da0405ed8b83a22e3f1bc584c0353485cabf3317ed82b4cca64dae0014febc9ae09a6532f869f35f9ba15c6008bd8f160eaba19e35cf90738630 SHA512 1cf180a337716f704d0e152a77049349aee9935273592b83aca64f3a9f926ed8775669114744ebf265dd09e70cf24af24e5c3e12a7bb3e7ecd90dc86f3cca3a6
+DIST genlisp-0.4.17.tar.gz 10154 BLAKE2B b16ccb9a5ad0e43906736786001b26e1de4548e40dfbf3bd24c4f2e6e1fcfb180a6dc7851f5a2c47d51dd247cc804f7cf7e3c023e88a2f442958c9ff59547ec4 SHA512 a86f4f921ff6e51323e1bf0e2ea5ada5dba106f6197b52ece4bbfe876951aead19ff9142395968bcccc06d83047232ecdad42f7ed9f380cf0f0a63e8717577dd
EBUILD genlisp-0.4.16.ebuild 412 BLAKE2B ddfb4fbe952db9ab12e4851be24396359a42f0350223b79ddac0119b5071263b6ce44499c6343cae56657601018cd8efa3acb9802721abda6e96d6a2dda6530d SHA512 f8d78d7358929aad7c555e648dc19f74b78b2dc273343b676fcb6a3844005bd219bde48ab20b34cd13e3f1b10f7d61e44d5cf40629fdab31722e96d2e54d9f54
+EBUILD genlisp-0.4.17.ebuild 412 BLAKE2B ddfb4fbe952db9ab12e4851be24396359a42f0350223b79ddac0119b5071263b6ce44499c6343cae56657601018cd8efa3acb9802721abda6e96d6a2dda6530d SHA512 f8d78d7358929aad7c555e648dc19f74b78b2dc273343b676fcb6a3844005bd219bde48ab20b34cd13e3f1b10f7d61e44d5cf40629fdab31722e96d2e54d9f54
EBUILD genlisp-9999.ebuild 412 BLAKE2B ddfb4fbe952db9ab12e4851be24396359a42f0350223b79ddac0119b5071263b6ce44499c6343cae56657601018cd8efa3acb9802721abda6e96d6a2dda6530d SHA512 f8d78d7358929aad7c555e648dc19f74b78b2dc273343b676fcb6a3844005bd219bde48ab20b34cd13e3f1b10f7d61e44d5cf40629fdab31722e96d2e54d9f54
MISC metadata.xml 325 BLAKE2B 0aaea5b7b4f0c686a5c27a7551d9b33da2fee26858b13837bc30810b880a0b70850b7f85d6cdaa7b60975cc66087f4a0370d417ef1879659737530617696b5dc SHA512 f1bda8492546d5a2cecaed684a06df6d41b1b1883cf1dba70dd51f88993a5466924394468d750fc5778bd1530b660e12c0d1e186f30530e5919c9a46a9382159
diff --git a/dev-ros/genlisp/genlisp-0.4.17.ebuild b/dev-ros/genlisp/genlisp-0.4.17.ebuild
new file mode 100644
index 000000000000..1c014b8cd52c
--- /dev/null
+++ b/dev-ros/genlisp/genlisp-0.4.17.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/genlisp"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Common-Lisp ROS message and service generators"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"