summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_ros
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/gazebo_ros
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest5
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild35
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-9999.ebuild35
-rw-r--r--dev-ros/gazebo_ros/metadata.xml11
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
new file mode 100644
index 000000000000..fa1f48a604b3
--- /dev/null
+++ b/dev-ros/gazebo_ros/Manifest
@@ -0,0 +1,5 @@
+DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 SHA256 48f1b1878819a424147195e0b3fa010aaf7b5f7a40ffef522c153f1adc6d3ae0 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3 WHIRLPOOL aa13810a8fbcde4de2c078c89542285cda61f47228bfbe2b237027a920ea5a01ccd823fd1d87d37923202d3a8b88a9017eccc44f1359da32a57cea23489a9948
+EBUILD gazebo_ros-2.6.2.ebuild 1009 SHA256 77ff2f41c43c4f2d89c1e856d45ff3c782b6b5fe74b8e90989692a25c3603f69 SHA512 61c285486cf13f06346311cd83bb04c4c9dc87963ec2927d658a8782a5a4b43fe7f54bf07127652f20ae9dde473f1234e3fd2fc84b691f665b9f6d95f978c132 WHIRLPOOL b77cda3f95e80af9187f0b1af7a6ff0267aaf0bee6ea3c518ebdea0bfb36bc8033676aa76ed9977588cd589af270bdd8767a53175426b43e293b737408665b50
+EBUILD gazebo_ros-9999.ebuild 1009 SHA256 77ff2f41c43c4f2d89c1e856d45ff3c782b6b5fe74b8e90989692a25c3603f69 SHA512 61c285486cf13f06346311cd83bb04c4c9dc87963ec2927d658a8782a5a4b43fe7f54bf07127652f20ae9dde473f1234e3fd2fc84b691f665b9f6d95f978c132 WHIRLPOOL b77cda3f95e80af9187f0b1af7a6ff0267aaf0bee6ea3c518ebdea0bfb36bc8033676aa76ed9977588cd589af270bdd8767a53175426b43e293b737408665b50
+MISC ChangeLog 2327 SHA256 ec7b3ed099894016f2eff5bc3a175030a2101f72a0add095fea99c71b3a7d310 SHA512 ddf34950555e8efec1d6cddfcc287f9b69a71d55496dc82aa119d7e97ac7914caa1b9b0ebd64aa91cc4a05687489b9e14e9985ae91f0ea684f8352e57d76762a WHIRLPOOL edb3ae60c72fadbc4d3aaf1f7f3d5d3d3759238e04ed1d8c2a38407f7df8e5fd63bf7e33c9c70d93f75528160cd1f7eb6f0ae98a81d5342cf29da573645c3c7a
+MISC metadata.xml 344 SHA256 f5e01eabfb9055df59f1c8079b8ef0cad9041892fe2b4853ecadf3ce1a14718b SHA512 9b7223f95a007995d9a626aa653d2f0f8dc84364c325109fbd9b2f84f0359db12f2d2e3d16391f33364627082f52f8bac6b81c1992d64630bd70e476ce2c5d4d WHIRLPOOL 95bcc2bd5a88e1f205dc349076f7dd929355fbb4435281b50dac76d2542c2f9f7c74fa7e0965d9a9d644eeb212a0a272011fe4364107745a9dcc103ee5a16dc6
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild
new file mode 100644
index 000000000000..168e26eb91b1
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
new file mode 100644
index 000000000000..168e26eb91b1
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros/metadata.xml b/dev-ros/gazebo_ros/metadata.xml
new file mode 100644
index 000000000000..ca1574a351fc
--- /dev/null
+++ b/dev-ros/gazebo_ros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-simulation/gazebo_ros_pkgs</remote-id>
+ </upstream>
+</pkgmetadata>