summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/gazebo_msgs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/gazebo_msgs')
-rw-r--r--dev-ros/gazebo_msgs/Manifest5
-rw-r--r--dev-ros/gazebo_msgs/gazebo_msgs-2.6.2.ebuild20
-rw-r--r--dev-ros/gazebo_msgs/gazebo_msgs-9999.ebuild20
-rw-r--r--dev-ros/gazebo_msgs/metadata.xml11
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/gazebo_msgs/Manifest b/dev-ros/gazebo_msgs/Manifest
new file mode 100644
index 000000000000..dc14aab8f3ed
--- /dev/null
+++ b/dev-ros/gazebo_msgs/Manifest
@@ -0,0 +1,5 @@
+DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 SHA256 48f1b1878819a424147195e0b3fa010aaf7b5f7a40ffef522c153f1adc6d3ae0 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3 WHIRLPOOL aa13810a8fbcde4de2c078c89542285cda61f47228bfbe2b237027a920ea5a01ccd823fd1d87d37923202d3a8b88a9017eccc44f1359da32a57cea23489a9948
+EBUILD gazebo_msgs-2.6.2.ebuild 582 SHA256 bf5821260e74b0250e63c51e645f35f6624f28e1f5bfc9a0de87ff1951e18b45 SHA512 fe7a4b20c7e040eae416625326e4f4879a6ae3661981153d11e14711e48cffbdc92d65b503f835f4d4c40722f631c2ea4c6eb04b59993b9ed5466a6ea151f506 WHIRLPOOL be133cc62111e1be397df907ef792bc92624c51f599cdbbd1a494692cf44a9e795a9089f213449cd94b55fcd829156f4d6699fa72e79465af6fac0780c8309c2
+EBUILD gazebo_msgs-9999.ebuild 582 SHA256 bf5821260e74b0250e63c51e645f35f6624f28e1f5bfc9a0de87ff1951e18b45 SHA512 fe7a4b20c7e040eae416625326e4f4879a6ae3661981153d11e14711e48cffbdc92d65b503f835f4d4c40722f631c2ea4c6eb04b59993b9ed5466a6ea151f506 WHIRLPOOL be133cc62111e1be397df907ef792bc92624c51f599cdbbd1a494692cf44a9e795a9089f213449cd94b55fcd829156f4d6699fa72e79465af6fac0780c8309c2
+MISC ChangeLog 2637 SHA256 d3617f148b7e2a29e5d26416174047c6a27540a636adb99c6370bf53c78a6c55 SHA512 90ab9d2186ab47b6d02ca630ce99198ac78148cf96b80e8ed1a7bdacf6a6bf33cb0423f5fc40737b3e23872d1dda306a69cf891fd5091380a4f0c23f70938bbc WHIRLPOOL 45c8b557d03e3918bbdd8adc0a01cb27be18614ba8c404ded8390c210846ee32b83f58b393ff1ee794ecd0d37aa21fdc165336114d8ff79c6ff15cc0ce25cdc5
+MISC metadata.xml 344 SHA256 f5e01eabfb9055df59f1c8079b8ef0cad9041892fe2b4853ecadf3ce1a14718b SHA512 9b7223f95a007995d9a626aa653d2f0f8dc84364c325109fbd9b2f84f0359db12f2d2e3d16391f33364627082f52f8bac6b81c1992d64630bd70e476ce2c5d4d WHIRLPOOL 95bcc2bd5a88e1f205dc349076f7dd929355fbb4435281b50dac76d2542c2f9f7c74fa7e0965d9a9d644eeb212a0a272011fe4364107745a9dcc103ee5a16dc6
diff --git a/dev-ros/gazebo_msgs/gazebo_msgs-2.6.2.ebuild b/dev-ros/gazebo_msgs/gazebo_msgs-2.6.2.ebuild
new file mode 100644
index 000000000000..37cca9c94864
--- /dev/null
+++ b/dev-ros/gazebo_msgs/gazebo_msgs-2.6.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/sensor_msgs dev-ros/trajectory_msgs dev-ros/std_msgs dev-ros/std_srvs"
+
+inherit ros-catkin
+
+DESCRIPTION="Message and service data structures for interacting with Gazebo from ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_msgs/gazebo_msgs-9999.ebuild b/dev-ros/gazebo_msgs/gazebo_msgs-9999.ebuild
new file mode 100644
index 000000000000..37cca9c94864
--- /dev/null
+++ b/dev-ros/gazebo_msgs/gazebo_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/geometry_msgs dev-ros/sensor_msgs dev-ros/trajectory_msgs dev-ros/std_msgs dev-ros/std_srvs"
+
+inherit ros-catkin
+
+DESCRIPTION="Message and service data structures for interacting with Gazebo from ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_msgs/metadata.xml b/dev-ros/gazebo_msgs/metadata.xml
new file mode 100644
index 000000000000..ca1574a351fc
--- /dev/null
+++ b/dev-ros/gazebo_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-simulation/gazebo_ros_pkgs</remote-id>
+ </upstream>
+</pkgmetadata>