summaryrefslogtreecommitdiff
path: root/dev-ros/dynamic_reconfigure
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/dynamic_reconfigure
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/dynamic_reconfigure')
-rw-r--r--dev-ros/dynamic_reconfigure/Manifest6
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild23
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.49.ebuild23
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild23
-rw-r--r--dev-ros/dynamic_reconfigure/metadata.xml11
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/Manifest b/dev-ros/dynamic_reconfigure/Manifest
new file mode 100644
index 000000000000..ba6e68791abe
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/Manifest
@@ -0,0 +1,6 @@
+DIST dynamic_reconfigure-1.5.48.tar.gz 38764 BLAKE2B 740500b05274c1ebe8423f3061f73fa54bec422b96598d3867b49b5b6d7d3f9d68172d796b49ee4a1b6d6f0c411d3ddd0b9b664cc8fdcef22bd9700f6dfb5111 SHA512 f4bdc00b580c56feaf3e076540d669923e1330c862fef3518774f43c57212dcbf28bb848f61e7196294d4e7439b4d06c33351aa8d133b71042b739ac59e105a6
+DIST dynamic_reconfigure-1.5.49.tar.gz 38883 BLAKE2B 499fc907c6015941caf151dd8b8f84ff90b1a9abb08d499be00ce4281957045cd50900eecc79be21c77dede125f2e5c03c2bbd7ebae0dc4b62637923dea0e0aa SHA512 c8cba24424142333df4d66c013915526573c791a4ef97e51baffe8040293dce67d313c57036807c308fe4ca17af92f277e467cde6494f166f6e4ec4aa34050cf
+EBUILD dynamic_reconfigure-1.5.48.ebuild 574 BLAKE2B b980c9a1eaec8427203b150628f390c37f3791ebefd356c0468d8f2c8780b428019f2bf333c90a6a15dea133f28e944f1eb8450085b0e6d743a9327e15e2036e SHA512 234041e10b2dcc1ce0bfa6785cb200e5f480102382b04bd361c7ac565b197328c86a009ba19243699841309978301821a30153b1a0dffce6a2520fc9bcaa7238
+EBUILD dynamic_reconfigure-1.5.49.ebuild 574 BLAKE2B b980c9a1eaec8427203b150628f390c37f3791ebefd356c0468d8f2c8780b428019f2bf333c90a6a15dea133f28e944f1eb8450085b0e6d743a9327e15e2036e SHA512 234041e10b2dcc1ce0bfa6785cb200e5f480102382b04bd361c7ac565b197328c86a009ba19243699841309978301821a30153b1a0dffce6a2520fc9bcaa7238
+EBUILD dynamic_reconfigure-9999.ebuild 574 BLAKE2B b980c9a1eaec8427203b150628f390c37f3791ebefd356c0468d8f2c8780b428019f2bf333c90a6a15dea133f28e944f1eb8450085b0e6d743a9327e15e2036e SHA512 234041e10b2dcc1ce0bfa6785cb200e5f480102382b04bd361c7ac565b197328c86a009ba19243699841309978301821a30153b1a0dffce6a2520fc9bcaa7238
+MISC metadata.xml 337 BLAKE2B c2b63166315cf868635f9abe7b49158c32f30d031cfd454ef9ebfb16fe7fc96c00cecc77c59bb3f91d4f07c77783bb2e1750d24f87da0507106355401ffe069b SHA512 19705df6cde1a0ae66f58cccc95a96e26302960f7e055a8c2b5fc15f0d995b2adaf0ac61c87470f7562e2ad03012845fd3abac6b4a081c1d6e01e9b91d53e561
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild
new file mode 100644
index 000000000000..9650a1395bcb
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.48.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.49.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.49.ebuild
new file mode 100644
index 000000000000..9650a1395bcb
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.49.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
new file mode 100644
index 000000000000..9650a1395bcb
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/dynamic_reconfigure/metadata.xml b/dev-ros/dynamic_reconfigure/metadata.xml
new file mode 100644
index 000000000000..76c48d2a3569
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/dynamic_reconfigure</remote-id>
+ </upstream>
+</pkgmetadata>