summaryrefslogtreecommitdiff
path: root/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
new file mode 100644
index 000000000000..a6bb2ae12003
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"