summaryrefslogtreecommitdiff
path: root/dev-ros/driver_base
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/driver_base
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/driver_base')
-rw-r--r--dev-ros/driver_base/Manifest4
-rw-r--r--dev-ros/driver_base/driver_base-1.6.8.ebuild20
-rw-r--r--dev-ros/driver_base/driver_base-9999.ebuild20
-rw-r--r--dev-ros/driver_base/metadata.xml11
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-ros/driver_base/Manifest b/dev-ros/driver_base/Manifest
new file mode 100644
index 000000000000..bd688bf80409
--- /dev/null
+++ b/dev-ros/driver_base/Manifest
@@ -0,0 +1,4 @@
+DIST driver_common-1.6.8.tar.gz 15055 BLAKE2B 2d9a4c23d65b8e2f60343f5e3b454e1cc41334d34e0246891b533f216acb743df628d95dd2c0087b06284a85e0ea872baad495a7ed7b59c03e8f8ff32eba4ed8 SHA512 b698143d08785088ac13e62f5b96676bd590a84e4ffb147fa3698be6a8ded510f648d043ecdc1d31ba7b95fb3041d06ee1a39b224c359b8612adebdba259d188
+EBUILD driver_base-1.6.8.ebuild 539 BLAKE2B 67f6b61796d89d43ee75e0875c7562692c29f31c3296acae620834eb933a41e411b59950494c12e1faaed4ad93c2153a14b9e9ca1d050db6861bf63263c1d725 SHA512 5a57dde52d032f0f949851e03bd4a73aa3ecf991f5d1fd7340b1c6b17e6c6a8e5e03113f4cdf58a20ef855255b41af469e10805e2a16fb64b15e6373d1704ba5
+EBUILD driver_base-9999.ebuild 539 BLAKE2B 67f6b61796d89d43ee75e0875c7562692c29f31c3296acae620834eb933a41e411b59950494c12e1faaed4ad93c2153a14b9e9ca1d050db6861bf63263c1d725 SHA512 5a57dde52d032f0f949851e03bd4a73aa3ecf991f5d1fd7340b1c6b17e6c6a8e5e03113f4cdf58a20ef855255b41af469e10805e2a16fb64b15e6373d1704ba5
+MISC metadata.xml 339 BLAKE2B 71ed9f79df6d8528f3d967c077f1d01e0290573400356e3749bd24254281651f09507894d2ca4029b8b8a77b51d31d080d9560d9995d3d9fde848f0d71ec083d SHA512 e24ff4ef526475ad5bff434350abb00afccb4c101ab624ee056c1502719d15ec4889eff9170c534af62ba8719bd5fe4f3cf206353244f56e486a29afea53ee7b
diff --git a/dev-ros/driver_base/driver_base-1.6.8.ebuild b/dev-ros/driver_base/driver_base-1.6.8.ebuild
new file mode 100644
index 000000000000..a156ea82b8e5
--- /dev/null
+++ b/dev-ros/driver_base/driver_base-1.6.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Framework for writing drivers that helps with runtime reconfiguration, diagnostics and self-test"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/driver_base/driver_base-9999.ebuild b/dev-ros/driver_base/driver_base-9999.ebuild
new file mode 100644
index 000000000000..a156ea82b8e5
--- /dev/null
+++ b/dev-ros/driver_base/driver_base-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Framework for writing drivers that helps with runtime reconfiguration, diagnostics and self-test"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/driver_base/metadata.xml b/dev-ros/driver_base/metadata.xml
new file mode 100644
index 000000000000..e4029ce25b8b
--- /dev/null
+++ b/dev-ros/driver_base/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-drivers/driver_common</remote-id>
+ </upstream>
+</pkgmetadata>