summaryrefslogtreecommitdiff
path: root/dev-ros/diagnostic_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/diagnostic_msgs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/diagnostic_msgs')
-rw-r--r--dev-ros/diagnostic_msgs/Manifest5
-rw-r--r--dev-ros/diagnostic_msgs/diagnostic_msgs-1.12.5.ebuild20
-rw-r--r--dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild20
-rw-r--r--dev-ros/diagnostic_msgs/metadata.xml11
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_msgs/Manifest b/dev-ros/diagnostic_msgs/Manifest
new file mode 100644
index 000000000000..ffceb390e7cb
--- /dev/null
+++ b/dev-ros/diagnostic_msgs/Manifest
@@ -0,0 +1,5 @@
+DIST common_msgs-1.12.5.tar.gz 59525 SHA256 816d96927e7aa6aa4972d5b9dfa3a1c71421cd9c15796d1f5f721ef947ee7fc3 SHA512 99efda88b630c0ebadc576501e9d84f3811fb012084125569d54da0b75656751f8f782d101fa0cf62d7b1ac4419902f17d1dc78efee7188ff67f59bf00a743ee WHIRLPOOL 9daf43c506c7ad76c48676d430b88aaf142810ee5633db1c9692732541765cbe82f56d0690a24239d6e70178a33c801159568e1ddd8c68780c60b176ebcbf39d
+EBUILD diagnostic_msgs-1.12.5.ebuild 509 SHA256 1a4ecfabe7752838258dfdd3c4bcf919e64fd6c499b75cd00607610f78211a71 SHA512 76dcfcdbbb83606453539a78636463a1dcbe05e906b32e6ab0029e9c4741334c5490a714077f86ad46a8f8f74b0093bad2f9dbb9a8700b41208d3fdef72be91b WHIRLPOOL bc2bc37b80f087d54842b6d7d0b5193dfe65fdf964ee452321dd043b936fe8dbfa388607e54e342869ef6dedec66e27e5fabead4f0625d7cf18fca29306256c3
+EBUILD diagnostic_msgs-9999.ebuild 509 SHA256 1a4ecfabe7752838258dfdd3c4bcf919e64fd6c499b75cd00607610f78211a71 SHA512 76dcfcdbbb83606453539a78636463a1dcbe05e906b32e6ab0029e9c4741334c5490a714077f86ad46a8f8f74b0093bad2f9dbb9a8700b41208d3fdef72be91b WHIRLPOOL bc2bc37b80f087d54842b6d7d0b5193dfe65fdf964ee452321dd043b936fe8dbfa388607e54e342869ef6dedec66e27e5fabead4f0625d7cf18fca29306256c3
+MISC ChangeLog 2191 SHA256 0d5c0aa22f50397069d05c4bca7bb140ef50c0c40854cf0e23ca0d83da1f7569 SHA512 81336833490908869ead2845e0ac8e56739a620883e498c122cbabb214ca885d91eb3c4eead071e08b61e6447fbaa335239620a10b6bae55a1de2b4fb95ff5dd WHIRLPOOL a289b733bdc2f9922c11698481579335fd69b65753c64a254146cbc598583afd38286e338008ba97f6fade14487a97a92cab34f3844e1b4758f8cb6d75e1d490
+MISC metadata.xml 329 SHA256 85be86f109c6730a8c5e1df55d92bf208589bb5e2e1b302052e1bf64187fe52f SHA512 0c4983993d1eec1067981913453de5b83fc2474c0af890dd388911039080a84c80881b3bc683aa01ceff35f511d2365292f15fb22f8ba10b188cace918dd1022 WHIRLPOOL 3db6b7e263a08b4409e27fefe1cd2046f4ed6796a41aae44fb608a984cb11ecc101818464fe61280ac1a2b572374639f54932114644e66852cbd46f60cd06af4
diff --git a/dev-ros/diagnostic_msgs/diagnostic_msgs-1.12.5.ebuild b/dev-ros/diagnostic_msgs/diagnostic_msgs-1.12.5.ebuild
new file mode 100644
index 000000000000..79e33707e8ec
--- /dev/null
+++ b/dev-ros/diagnostic_msgs/diagnostic_msgs-1.12.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for the diagnostic and runtime monitoring systems in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild b/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild
new file mode 100644
index 000000000000..79e33707e8ec
--- /dev/null
+++ b/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for the diagnostic and runtime monitoring systems in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/diagnostic_msgs/metadata.xml b/dev-ros/diagnostic_msgs/metadata.xml
new file mode 100644
index 000000000000..22d077d4b85a
--- /dev/null
+++ b/dev-ros/diagnostic_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/common_msgs</remote-id>
+ </upstream>
+</pkgmetadata>