summaryrefslogtreecommitdiff
path: root/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
index 2e621e904b7b..bee85b1f78d7 100644
--- a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -14,15 +13,20 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/roscpp
- media-libs/opencv:=
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
dev-ros/image_geometry
dev-ros/image_transport
dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+
+ media-libs/opencv:=
dev-libs/boost:=
dev-libs/console_bridge:=
"
-DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ test? (
+ dev-cpp/gtest
+ )
+"
+PATCHES=( "${FILESDIR}/isnan.patch" )