summaryrefslogtreecommitdiff
path: root/dev-ros/depth_image_proc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/depth_image_proc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/depth_image_proc')
-rw-r--r--dev-ros/depth_image_proc/Manifest6
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild31
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-1.12.23.ebuild31
-rw-r--r--dev-ros/depth_image_proc/depth_image_proc-9999.ebuild31
-rw-r--r--dev-ros/depth_image_proc/metadata.xml11
5 files changed, 110 insertions, 0 deletions
diff --git a/dev-ros/depth_image_proc/Manifest b/dev-ros/depth_image_proc/Manifest
new file mode 100644
index 000000000000..e9521d0a8560
--- /dev/null
+++ b/dev-ros/depth_image_proc/Manifest
@@ -0,0 +1,6 @@
+DIST image_pipeline-1.12.22.tar.gz 139237 BLAKE2B 9c4ad324494f7e9db935cceed562840bb7ed7af730655398c9ac410722faf7d6747010ef0bbee55f14b555b6b2a6756de3edde31d84c3ae3fad123cea4a85bfe SHA512 34c17bd13625dc0a3c94639ce5ea17cc7674b0035b425c10020178d08037fb4fd081a84d7e83c75822f58c0ba2faead351702dbbc75c821d2f8c17bda351c560
+DIST image_pipeline-1.12.23.tar.gz 139986 BLAKE2B 22349762d6119a2246cb812cce310ebe98b046881ea1192425c4a0ebd7717b8e2768cd4f357ebf905f81e2be9816b7b864ee1040e570d156f9377f51386274a1 SHA512 cb9df1845ae3e7a08788e8f401b8e1b5354cc06f9a4b1aa62d2729c5d84033adbc0049a837236644a0b89951a172b230d4c074bc403bb265ba6cf0ad8016dbdd
+EBUILD depth_image_proc-1.12.22-r1.ebuild 732 BLAKE2B 16cf7f434921ef6754dee1ef95da566b2a13267c9b51f6d8da7515e36e8696da505e1a43650c0536595e0ab12912b7176ad4f0aecaaaf6bd77c9fd957c28f28c SHA512 c81f37aacce8a8ea5a41d735e6411d8a03b8ae834ee76ffc54dffc46296c7afae845cbfadae49bc189d9438e81569bab82eb2e4d0e193bc836e8b47e079e1681
+EBUILD depth_image_proc-1.12.23.ebuild 732 BLAKE2B a5ab72714539b5c587ede8dd2a791e45f8016fe934765bb0132555b78ece1174351ef31b1bfed432eda62d5c85e1094bba244a8e3622dcd5487a2956e08fc58c SHA512 87982442ec87ce04625e18f3df7256aceb7fc85130319aebd490e920a144e53370e1dee481d4233d4cbace5477de29dfd12456df7bd33ca18c312abf387a06ea
+EBUILD depth_image_proc-9999.ebuild 732 BLAKE2B 16cf7f434921ef6754dee1ef95da566b2a13267c9b51f6d8da7515e36e8696da505e1a43650c0536595e0ab12912b7176ad4f0aecaaaf6bd77c9fd957c28f28c SHA512 c81f37aacce8a8ea5a41d735e6411d8a03b8ae834ee76ffc54dffc46296c7afae845cbfadae49bc189d9438e81569bab82eb2e4d0e193bc836e8b47e079e1681
+MISC metadata.xml 343 BLAKE2B 338674597d8027dfe18c53c2322f9f1ad7cb177c988a820dfbacbb45cf25ed32fbb65fc0fe08de174b20933d2cbfb7118e1d01b5e9d852f226cbd581da046bb4 SHA512 c16dd878a20c747d32f8445c8eb454b51ffaf8543c1f722cca0e6508d849107e89a2cda92b0d206ef618ae1075d51e542c4178e903f3cb35efd285a5fff0cfcb
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild
new file mode 100644
index 000000000000..65c78ae415a8
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-1.12.22-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/depth_image_proc/depth_image_proc-1.12.23.ebuild b/dev-ros/depth_image_proc/depth_image_proc-1.12.23.ebuild
new file mode 100644
index 000000000000..85a496111029
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-1.12.23.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild b/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild
new file mode 100644
index 000000000000..65c78ae415a8
--- /dev/null
+++ b/dev-ros/depth_image_proc/depth_image_proc-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelets for processing depth images such as those produced by OpenNI camera"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/eigen_conversions
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/depth_image_proc/metadata.xml b/dev-ros/depth_image_proc/metadata.xml
new file mode 100644
index 000000000000..7536ca01cdf7
--- /dev/null
+++ b/dev-ros/depth_image_proc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_pipeline</remote-id>
+ </upstream>
+</pkgmetadata>