summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ros/cv_bridge/files
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ros/cv_bridge/files')
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch20
-rw-r--r--dev-ros/cv_bridge/files/ocv_leak.patch20
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
deleted file mode 100644
index a6192f98be24..000000000000
--- a/dev-ros/cv_bridge/files/boostpython.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: cv_bridge/CMakeLists.txt
-===================================================================
---- cv_bridge.orig/CMakeLists.txt
-+++ cv_bridge/CMakeLists.txt
-@@ -5,14 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
-
- if(NOT ANDROID)
- find_package(PythonLibs)
--
-- if(PYTHONLIBS_VERSION_STRING VERSION_LESS "3.8")
-- # Debian Buster
-- find_package(Boost REQUIRED python37)
-- else()
-- # Ubuntu Focal
-- find_package(Boost REQUIRED python)
-- endif()
-+ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
- else()
- find_package(Boost REQUIRED)
- endif()
diff --git a/dev-ros/cv_bridge/files/ocv_leak.patch b/dev-ros/cv_bridge/files/ocv_leak.patch
deleted file mode 100644
index dab21616fc89..000000000000
--- a/dev-ros/cv_bridge/files/ocv_leak.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Index: cv_bridge/CMakeLists.txt
-===================================================================
---- cv_bridge.orig/CMakeLists.txt
-+++ cv_bridge/CMakeLists.txt
-@@ -17,14 +17,7 @@ else()
- find_package(Boost REQUIRED)
- endif()
-
--set(_opencv_version 4)
--find_package(OpenCV 4 QUIET)
--if(NOT OpenCV_FOUND)
-- message(STATUS "Did not find OpenCV 4, trying OpenCV 3")
-- set(_opencv_version 3)
--endif()
--
--find_package(OpenCV ${_opencv_version} REQUIRED
-+find_package(OpenCV 4 REQUIRED
- COMPONENTS
- opencv_core
- opencv_imgproc