summaryrefslogtreecommitdiff
path: root/dev-ros/cv_bridge/files/boostpython.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/cv_bridge/files/boostpython.patch
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/cv_bridge/files/boostpython.patch')
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
index 72fac8087363..a6192f98be24 100644
--- a/dev-ros/cv_bridge/files/boostpython.patch
+++ b/dev-ros/cv_bridge/files/boostpython.patch
@@ -2,14 +2,17 @@ Index: cv_bridge/CMakeLists.txt
===================================================================
--- cv_bridge.orig/CMakeLists.txt
+++ cv_bridge/CMakeLists.txt
-@@ -5,11 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+@@ -5,14 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
if(NOT ANDROID)
find_package(PythonLibs)
-- if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
-- find_package(Boost REQUIRED python)
+-
+- if(PYTHONLIBS_VERSION_STRING VERSION_LESS "3.8")
+- # Debian Buster
+- find_package(Boost REQUIRED python37)
- else()
-- find_package(Boost REQUIRED python3)
+- # Ubuntu Focal
+- find_package(Boost REQUIRED python)
- endif()
+ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
else()