summaryrefslogtreecommitdiff
path: root/dev-ros/compressed_image_transport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/compressed_image_transport
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/compressed_image_transport')
-rw-r--r--dev-ros/compressed_image_transport/Manifest5
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-1.9.5.ebuild24
-rw-r--r--dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild24
-rw-r--r--dev-ros/compressed_image_transport/metadata.xml11
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/compressed_image_transport/Manifest b/dev-ros/compressed_image_transport/Manifest
new file mode 100644
index 000000000000..fee289dfde0c
--- /dev/null
+++ b/dev-ros/compressed_image_transport/Manifest
@@ -0,0 +1,5 @@
+DIST image_transport_plugins-1.9.5.tar.gz 26268 SHA256 a3dcd3af617bcafba5b8dab5fbd89183fbaf31798ee4e4e63a91059fa110168c SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c WHIRLPOOL 1796f983cd0a904b6cce58ecec4a59034ab23ca8ca7a3c2a9b3fa8764d60c1426754c3a6bdb9eaf8bcff1859768af76b3d4f3a3350ee6cd6af5cc89f90ae639a
+EBUILD compressed_image_transport-1.9.5.ebuild 567 SHA256 f532ab737a0019c572fb55d1601cd34fc81c6cf9b02764a7aac58bd84cd0d192 SHA512 e1873c33d05b38d2b55613fe24019808cec11f88c50c08602255a0e5a950c7a9de63b002024204709d7588404059caa685be7be9e3c7d11b086515409c439cf1 WHIRLPOOL 1caa486c33cb6e4683681e6ffb3a5fa7cbcb5cd51cbd8f4a00148a04ee49af46383fdeffda7a32f02c9efda831e588b64a8254305cd86bbfe6708b72279919ca
+EBUILD compressed_image_transport-9999.ebuild 567 SHA256 f532ab737a0019c572fb55d1601cd34fc81c6cf9b02764a7aac58bd84cd0d192 SHA512 e1873c33d05b38d2b55613fe24019808cec11f88c50c08602255a0e5a950c7a9de63b002024204709d7588404059caa685be7be9e3c7d11b086515409c439cf1 WHIRLPOOL 1caa486c33cb6e4683681e6ffb3a5fa7cbcb5cd51cbd8f4a00148a04ee49af46383fdeffda7a32f02c9efda831e588b64a8254305cd86bbfe6708b72279919ca
+MISC ChangeLog 2371 SHA256 d859ef2acd3ee390405ee88e08609c6705615c6f4c823add7a44984591f0ad07 SHA512 cb650ecf59170c9ee0706c7358c9c6556c810973f1816bde001c124af6dbe8ce64a5b700f005efaa1e31e8e0b3fe11e36cfba5c977ed947826246b7746a5b4c6 WHIRLPOOL 54c92f2dfc9fa84b9d448f100f68fbcaad75a37140cd759d99f26948afc55cde408f302002e49e59808ce33855f1781f277365300fdf7fde0c3ec0fb48375595
+MISC metadata.xml 352 SHA256 7531295b37e1b7807944e69f310c2892596e0fe8ed15decb854b1c687ce48422 SHA512 855c756eea98c52acb020fb394646008db35b41b864a0983f67bbf07ffce658d394c0de13d6622286770e4aa4152b74f2f6028c575b11b66233431d1fffa0347 WHIRLPOOL e87c5707d2ab0f2d6e03b845b2fffa93bb023722d1d6635013e4341052c5bd58bc6010ab0e82ed9959f80cdfb68383bc395f8752f0cd6f6d20b708c78a3cec5c
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5.ebuild
new file mode 100644
index 000000000000..23f4c2554ecf
--- /dev/null
+++ b/dev-ros/compressed_image_transport/compressed_image_transport-1.9.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild b/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild
new file mode 100644
index 000000000000..23f4c2554ecf
--- /dev/null
+++ b/dev-ros/compressed_image_transport/compressed_image_transport-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending images encoded as JPEG or PNG"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_image_transport/metadata.xml b/dev-ros/compressed_image_transport/metadata.xml
new file mode 100644
index 000000000000..feed05c03f5b
--- /dev/null
+++ b/dev-ros/compressed_image_transport/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_transport_plugins</remote-id>
+ </upstream>
+</pkgmetadata>