summaryrefslogtreecommitdiff
path: root/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild')
-rw-r--r--dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild
new file mode 100644
index 000000000000..385e41ceda38
--- /dev/null
+++ b/dev-ros/clear_costmap_recovery/clear_costmap_recovery-1.17.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Recovery behavior that attempts reverting the costmaps to the static map"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16.3
+ dev-cpp/eigen:3
+ dev-ros/nav_core
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=[threads(+)]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? ( dev-ros/rostest dev-cpp/gtest )
+"