summaryrefslogtreecommitdiff
path: root/dev-ros/camera_calibration_parsers/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/camera_calibration_parsers/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/camera_calibration_parsers/files')
-rw-r--r--dev-ros/camera_calibration_parsers/files/boostpython.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/files/boostpython.patch b/dev-ros/camera_calibration_parsers/files/boostpython.patch
new file mode 100644
index 000000000000..8e2b868ec452
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/files/boostpython.patch
@@ -0,0 +1,20 @@
+Revert special handling not needed on Gentoo.
+https://bugs.gentoo.org/show_bug.cgi?id=608330
+
+Index: camera_calibration_parsers/CMakeLists.txt
+===================================================================
+--- camera_calibration_parsers.orig/CMakeLists.txt
++++ camera_calibration_parsers/CMakeLists.txt
+@@ -4,11 +4,7 @@ project(camera_calibration_parsers)
+ find_package(catkin REQUIRED sensor_msgs rosconsole roscpp roscpp_serialization)
+
+ find_package(PythonLibs REQUIRED)
+-if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
+- find_package(Boost REQUIRED COMPONENTS filesystem python)
+-else()
+- find_package(Boost REQUIRED COMPONENTS filesystem python3)
+-endif()
++find_package(Boost REQUIRED COMPONENTS filesystem python)
+ include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+
+ catkin_python_setup()