summaryrefslogtreecommitdiff
path: root/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild')
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
new file mode 100644
index 000000000000..9e586eb4d9df
--- /dev/null
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-1.12.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/image_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Routines for reading and writing camera calibration parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-libs/boost:=[python,\${PYTHON_USEDEP}]")
+ dev-ros/rosconsole
+ >=dev-cpp/yaml-cpp-0.5:=
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rosbash
+ )
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+PATCHES=( "${FILESDIR}/boostpython.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}