summaryrefslogtreecommitdiff
path: root/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
deleted file mode 100644
index 65951f6a974b..000000000000
--- a/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-perception/calibration"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
- dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
- dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
- dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
- dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- $(python_gen_cond_dep "dev-python/matplotlib[\${PYTHON_USEDEP}]")
- $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
- $(python_gen_cond_dep "dev-python/scipy[\${PYTHON_USEDEP}]")
- $(python_gen_cond_dep "dev-python/urdf_parser_py[\${PYTHON_USEDEP}]")
-"
-DEPEND="${RDEPEND}
- test? (
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-
-src_prepare() {
- ros-catkin_src_prepare
- sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
-}
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
-}