summaryrefslogtreecommitdiff
path: root/dev-ros/bond/bond-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-ros/bond/bond-1.8.2.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-ros/bond/bond-1.8.2.ebuild')
-rw-r--r--dev-ros/bond/bond-1.8.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/bond/bond-1.8.2.ebuild b/dev-ros/bond/bond-1.8.2.ebuild
new file mode 100644
index 000000000000..428c29774191
--- /dev/null
+++ b/dev-ros/bond/bond-1.8.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/bond_core"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="A bond allows two processes, A and B, to know when the other has terminated"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"