summaryrefslogtreecommitdiff
path: root/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild')
-rw-r--r--dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
new file mode 100644
index 000000000000..43acf79bb21d
--- /dev/null
+++ b/dev-ros/ament_uncrustify/ament_uncrustify-0.10.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against style conventions using uncrustify"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-util/uncrustify
+"
+DEPEND=""
+BDEPEND=""